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Welcome to the World of Bokeh

What is Bokeh?
In photography, bokeh (derived from the Japanese ボケ味) refers to the visually distinctive 
character of the out-of-focus areas of a photograph. Alien Skin’s Bokeh plug-in is a realistic 
lens simulator that allows you to alter the depth-of-field of a photograph after it has been taken. 
It can also be used to simulate tilt-shift and vignetting effects commonly used by photographers 
to draw the viewer’s attention to certain areas of a photograph. The following highlights the 
major features of Bokeh:

Easily create tilt-shift effects (e.g. Lensbaby) using the built-in radial and planar  •	
	 region shapes.

Simulate realistic depth-of-field effects by importing selection masks from Photoshop.•	

Create distinctive bokeh highlights using different diaphragm shapes.•	

Plenty of creative controls to simulate many types of bokeh from smooth creamy bokeh  •	
	 to fancy heart-shaped highlights.

Use natural vignetting to simulate real lens effects (e.g. Lomo) or creative vignetting  •	
	 to focus the viewer’s attention to any region in your photograph.

Ability to save, recall and share your favorite Bokeh settings.•	
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Installation (same for both Macintosh and Windows)
Shut down your graphics host program (usually Photoshop).

Run the installer found on the CD or that you downloaded.

You will be asked to enter the username and password of an account with administrator 
privileges. If you don’t have administrator privileges, talk to your IT gal or consult your Mac OS 
or Windows manual.

After the license agreement screen, you will see a list of compatible graphics programs on your 
computer. Choose one and click OK. If you want to install into another graphics program, run 
the installer again.

Activation
Bokeh has an activation system that works just like the one in Photoshop. Until Bokeh is 
activated, each time it starts it will ask you to activate. Activation is a very quick and easy 
process in which Bokeh lets our activation server know that your license code is in use. This 
only needs to be done once. Bokeh does not talk to our activation server again after it has been 
activated. No personal information is sent other than the license code.

You can use Bokeh for up to 30 days without activating. After that, Bokeh will stop working until 
you activate it.

You can have Bokeh activated on up to two computers at once, so you can have it on both your 
laptop and desktop computers. If you ever get rid of your computer, don’t forget to deactivate 
Bokeh first! You can do that by going to the menu entry Help>Deactivate. Then you can 
activate Bokeh on a new computer.

Other Sources of Help
This manual is just one of many sources of help for Bokeh. Once you start Bokeh, check out the 
Help menu for links to lots of helpful parts of our web site, including video tutorials. The video 
tutorial on getting started is a great one to watch before you run Bokeh for the first time. Also 
watch the text at the bottom of the Bokeh window to learn about whatever your cursor is near.
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User Interface Overview
The next few sections give detailed info on what every control in the Bokeh user interface does. 
Screen shots are randomly from a Macintosh or Windows computer, whichever was handy at 
the time. All the gizmos are in the same places and behave the same way on both platforms. 
They are just more shiny on the Mac.

Below is a screen shot of the Bokeh user interface with the Settings Tab selected.

A: Title Bar
The title bar displays the currently selected setting.

B: Tabs
The Settings Tab lets you quickly select a preset or one of your saved custom settings. The 
Bokeh and Vignette Tabs let you manipulate every aspect of the filter. Each tab is described in 
detail in later sections.

C: Navigation Thumbnail	
Click and drag the movable red box to quickly move the preview around your image.

D: UpToDate Message Indicator
When you see this visual cue, you have a new message from Alien Skin Software. Click here to 
open a web page containing the message. UpToDate messages are usually announcements of 
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updates, new products, or our monthly newsletter. You can set the frequency that UpToDate 
checks for messages or turn it completely off in the Preferences dialog.

E: Ok and Cancel
Clicking the OK button applies the filter with the current settings. Clicking Cancel closes the 
filter window without applying the effect. The Enter key is the same as clicking OK and Escape 
is the same as clicking Cancel.

F: Preview Tools (only one at a time is active)
Click and hold the Show Original Button to see the unmodified form of the image. 
An easier way to do this is to simply hold down the Spacebar.

Click the hand to enable the Move Tool. Then click and drag in the preview to move 
around the image.

Click the magnifying glass to enable the Zoom Tool. Then you can click in the preview 
window to zoom in. Option+click (Macintosh) or Alt+click (Windows) to zoom out. 

Double-clicking the magnifying glass resets the preview window to 100% magnification. While 
in zoom mode, holding down the Spacebar temporarily switches to the Move Tool. Many of the 
same shortcut keys that Photoshop uses to navigate a preview window work in Bokeh too.

Click the arrow to enable the Adjustment Tool. While this tool is active, you can see 
and manipulate focus region shapes overlaid on the preview. The type of focus region 

is set on the Bokeh Tab.

G: Split Screen Preview
Above the preview area is a menu of options for split screen previewing. When enabled, this 
feature shows the original image in half of the preview. The entries in the Split Screen menu 
specify the orientation of the split line or simply turn it off.

H: Preview Area
Preview the effect on your image here. Resize the filter window to make the preview area larger 
or smaller.

I: Focus Region Controls
When the Focus Region is set to Radial or Planar, special controls are drawn on top of the 
preview. The screen shot shows the Planar controls. You can only see and manipulate these 
controls when you are using the Adjustment Tool, which is the arrow above the preview.

J: Mouseover Help
Whenever you move your cursor over a user interface element, a short description appears in 
the bottom left corner of the window.
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K: Progress Bar and Magnification Indicator
While the preview is being drawn, a progress bar is drawn to the left of the magnification 
indicator. The magnification indicator shows the current zoom level of the preview.

Menus
Command menus are accessible when you launch Bokeh. Macintosh users will see the menus 
in place of their usual menu bar. Windows users will see the menus at the top of the plug-in 
window.

Edit Menu
The Edit menu provides an unlimited ability to undo or redo changes. If you experiment with the 
sliders and find that you prefer a previous group of settings, select the Undo command from the 
Edit menu or click Command+Z (Control+Z on Windows) to back up as many times as 
necessary. The Edit menu also lets you copy, cut, and paste values from parameter fields.

View Menu
The View menu lets you zoom the preview in and out. To display the entire image in the preview 
window, select Fit On Screen. To display the preview at 100% magnification, select Actual 
Pixels. See Keyboard Shortcuts for some nifty zooming shortcuts. 

Help Menu
From the Help menu you can read the PDF manual (this document). The same assistance can 
be reached by pressing F1 (Windows) or Help (Macintosh).

There are Help menu entries that go to the following places on our Web site:

Video Tutorials•	

Bokeh Product Web Page•	

Alien Skin Software’s Home Page•	

Online Forums•	

Support Knowledgebase•	

UpToDate Messages •	

From the Help menu you can Activate or Deactivate the locally installed copy of Bokeh. See the 
Activation section earlier in this document for more information.
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Preferences
Select Edit>Preferences (Windows) or Photoshop>Preferences (Macintosh) to modify 
preferences. You can also get there by typing Command+K (Macintosh) or Control+K 
(Windows). 

UpToDate
Here you can set the frequency at which the UpToDate system checks for messages from 
Alien Skin Software. The UpToDate system informs you about the latest Alien Skin Software 
products, special offers, software updates and other news. When a new message is ready, a 
button will appear at the top of the user interface labeled “Click here for new messages from 
Alien Skin.”

Preview Background
If you use layers with transparency, you can set the color or pattern that is drawn to represent 
transparent pixels in the preview.

Favor Memory or Speed
If Bokeh runs out of memory, try moving this slider toward the Memory side. Then restart 
Photoshop and you may find that the problem goes away. If you are using images over 4 
megapixels, then you may get a mild speed boost by moving the slider toward the Speed side.

Disable Output On New Layer
Most of the time, the capability to render Bokeh’s output to a new layer is handy. This can be 
done by turning on the checkbox on the Bokeh Tab named “Create Output In New Layer Above 
Current”. However, that feature is not compatible with Photoshop actions. If you record an 
action with that checkbox on, nothing will happen when you play the action back. If you are 
going to record a lot of actions, it is useful to turn this feature off in the Preferences dialog.
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Keyboard Shortcuts
Shortcut Function	 Macintosh	 Windows

Navigate to Next Control	 Tab	 Tab

Navigate to Previous Control	 Shift+Tab	 Shift+Tab

OK	 Return	 Enter

Cancel	 Escape	 Escape

Undo	 ⌘+Z	 Ctrl+Z

Redo	 ⌘+Y	 Ctrl+Y

Cut	 ⌘+X	 Ctrl+X

Copy	 ⌘+C	 Ctrl+C

Paste	 ⌘+V	 Ctrl+V

Zoom In	 ⌘++	 Ctrl++

Zoom Out	 ⌘+-	 Ctrl+ -

Actual Pixels	 Option+⌘+Zero	 Alt+Ctrl+Zero

Fit on Screen	 ⌘+Zero	 Ctrl+Zero

Load Factory Default Setting	 ⌘+R	 F5

Load Last Used Setting	 ⌘+L	 Ctrl+L

Save Setting	 ⌘+S	 Ctrl+S

Switch to Move Tool (hand)	 H	 H

Switch to Zoom Tool	 Z	 Z

Switch to Adjustment Tool	 A	 A

Preview Move (with zoom enabled)	 Space Bar+Drag	 Space Bar+Drag

Zoom In (with zoom enabled)	 Mouse Click	 Left Mouse Click

Zoom In (with move enabled)	 ⌘+Click	 Ctrl+Click

Zoom Out	 Option + Mouse Click	 Alt + Mouse Click

Drag preview (with zoom enabled)	 Hold spacebar while dragging	 Hold spacebar while dragging
– also displays original image

Zoom to Actual Pixels	 Double-click Zoom Tool	 Double-click Zoom Tool

Increase/Decrease Slider by 1	 Up/Down Arrow	 Up/Down Arrow

Increase/Decrease Slider by 10	 Shift+Up/Down Arrow	 Shift+Up/Down Arrow

Open Manual	 ⌘+/ or Help	 F1

Open Preferences Dialog	 ⌘+K	 Ctrl+K
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Settings Tab

The Settings tab lets you create, manage, and share your favorite settings. There are two lists 
on the Settings tab. The top list contains factory settings. Factory settings are supplied with the 
product and can’t be changed. The bottom list contains user settings, which are settings you 
can create yourself.

Loading Settings
Simply click on a setting to move all the controls to the values saved in that setting. The only 
controls that are not loaded from a setting are the Region and Blur Controls section of the 
Bokeh Tab. We did that because you generally don’t want your radial sweet spot to move just 
because you are switching lens type.

Saving Settings
To save a setting, first adjust the sliders and other filter controls to your satisfaction. Then, click 
the Save Button at the bottom of the Settings Tab. You can also save a setting by pressing 
Command+S (Macintosh) or Control+S (Windows). The Save Setting dialog box will appear. 
There you can specify the name and category of the new setting. 

Modifying Settings
To modify the control values in a setting, move the controls and then save the setting with the 
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same name. This is easy because the Save Settings dialog is always filled out with the most 
recently loaded setting name.

You can also right-click (Windows) or Control-click (Macintosh) on a setting to rename, delete, 
export, or e-mail it.

Bokeh Tab

Region and Blur Controls
Bokeh can be used with and without a selection mask. Bokeh automatically detects the presence 
of a selection and changes the GUI controls appropriately, as shown in the following pictures.
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When there is no selection, you can choose between three built-in Focus Region options:

None:•	  With no focus region, the entire image is blurred.

Radial:•	  A radial sweet spot will appear over the image. The area within the solid oval is  
	 kept in focus. The area between the solid oval and the dashed oval will be blurred in a  
	 gradually increasing amount. The area outside the dashed oval will be blurred the most.

Planar: •	 A planar gradient is useful for creating a gradual change in the amount of blurring.

When a selection is used, you can choose between three ways to use the Focus Region options:

Selection Only:•	  By default, the area within the selection is kept in focus. The area outside  
	 the selection is blurred. This behavior can be reversed by using the Invert Selection option.

Selection and Radial:•	  A radial sweet spot is added to the selection region.

Selection and Planar:•	  A planar gradient is added to the selection.

Note that a selection can be used only if Bokeh is not run as a Smart Filter.

The radial sweet spot tool can be controlled by using the mouse to click and drag the regions 
labeled in the above picture.

A: Click and drag in any region within the dashed line to reposition the radial sweet spot.

B: Move any one of the four control points to make the radial shape more or less oval. If the 
Shift key is held down, the control points move in 45-degree increments.
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C: Move the solid oval to change the size of the radial sweet spot.

D: Move the dashed oval to change the feathering amount.

The planar gradient can be controlled 
by using the mouse to click and drag 
the two control points and the line, as 
labeled in the picture to the left. 

A: Move the large control point to 
change the location where the gradual 
blurring begins.

B: Move the line to reposition both the 
beginning and end of the gradual 
blurring.

C: Move the small control point to 
change the location where the gradual 
blurring ends.

Reset Region Controls
Use this button to reset the radial and 
planar tools to their default shapes.

Bokeh Amount
The “Bokeh Amount” slider controls the 
maximum amount of blur applied to the 

image. Some parts of the image may get less blur depending on the region you have specified.

Aperture Controls
These controls affect the shape of the lens aperture diaphragm and other attributes to generate 
realistic bokeh. The effects of changing these controls are most visible if there are point light 
sources in the image. If the scene is evenly illuminated with no highlights, the effects of 
changing these controls may not be obvious.

Diaphragm Shape
The shape of the diaphragm changes the shape of the circle of confusion, and hence the shape 
of the bokeh. A perfect circle is the most common shape for a wide open aperture and it is the 
default setting. Polygons or a heart shape are also possible.

Creamy
Bokeh that is soft and where the diaphragm shape is not obvious is often called “creamy”. This 
slider allows you to control the amount of creaminess you wish to add to an image.
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At negative values of creaminess, the bokeh becomes harsh and can appear as a ring for a 
circular diaphragm shape. This can sometimes be used for creative purposes.

Rotation

Use this control to rotate the shape of the diaphragm. This control is disabled when the shape 
is a perfect circle. 

Blade Curvature
By default, all blades are straight at 0% curvature. Positive curvature makes the shape more 
round. Negative curvature makes the shape more like a star. This control is enabled only for 
polygon shapes.

These pictures show how a highlight is affected by a 5-blade aperture.

Highlight Controls 
Bokeh effects are most visible when there are bright light sources in the scene being 
photographed. These controls can be used to boost highlights to make bokeh more visible. It is 
possible that a scene has no highlights and using these controls to boost midtones or shadows 
could produce ugly results.

Selection Threshold
Pixels brighter than this threshold are considered highlights. As this threshold is increased, 
more and more pixels are selected for boosting.

Boost Amount
This controls the amount of highlight boosting pixels get. Large boosting creates brighter and 
more visible highlights. 

High Creaminess High CurvatureLow Creaminess Low Curvature
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Vignette Tab

A vignette is a darkening of the border of an image. These controls simulate natural vignetting 
like that from real camera lenses. They also provide ways to create vignette effects to creatively 
focus attention to different parts of the image.

Vignette Shape
There are two types of vignette shape: Focus Region and Natural. When set to Focus Region, 
the position of the vignette shape follows the Focus Region shape set in the Bokeh tab. When 
set to Natural, the shape is an oval centered in the middle of the image.

Vignette Color
Traditionally, vignettes are black because they are caused by a reduction of light near the border 
of the image. For creative purposes, Bokeh allows vignettes to be generated in any color. 

Intensity 
This control changes the intensity of the vignette. At 0%, no vignette is applied. At 100%, some 
pixels will be completely changed to the vignette color, depending on the vignette shape. 

Size and Feather 
0% is the default size and feathering amount. If Focus Region is used as the Vignette Shape, 
these default values are those set in the Bokeh tab. The size and feathering amounts can be 
increased or decreased from their defaults using these sliders. 
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Vignette Shape is set to Focus Region and a radial focus region was placed over the baby’s head.

Vignette Shape is set to Natural. This just darkens the edges of the photo.
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