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Customer Support

Contact: http://thepluginsite.com/about/contact.htm

Web site: http://thepluginsite.com

User Forum: http://www.graphicsgalaxy.com/forums/thepluginsite/viewforum.php?f=26

If LightMachine can't cope with a photo, please contact us.
It will help us to make the next version of LightMachine even better.

Credits

Idea, Concept and Programming

by Harald Heim

Plugin Framework:

Windows Version by Harald Heim
(with code from Alex Hunter & Martijn Van Der Lee)

Mac Version by Digital Element

Graphics:

Logo and Artwork by Steve Upham
Dialog Design by Harald Heim

Many Thanks to the Beta Testers:
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Andrew Bokelman

LightMachine Manual 2

http://thepluginsite.com/about/contact.htm
http://thepluginsite.com
http://www.graphicsgalaxy.com/forums/thepluginsite/viewforum.php?f=26
http://thepluginsite.com/about/contact.htm
http://www.digitalelement.com
http://www.cybia.co.uk/


Steve Upham
Sonja Shea
Peter Mayer

James R Terrell
Robin Rowlands
Sally Beacham

Nelia
Shannon Carnevale

Lori G Davis
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To see the photos of the beta testers in LightMachine,
move the mouse over the preview and press the B key.
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Compatibility

LightMachine works under Windows 95, 98, NT, ME, 2000, XP, Vista as well as MacOS X. It supports the 8−bit RGB and
16−bit RGB color modes. You need one of the following applications to use it:

You need one of the following applications to use the Mac Version:

Adobe Photoshop (Version 7 and higher)• 
Adobe ImageReady (Version 7 and higher)• 
Adobe Photoshop Elements (Version 2 and higher)• 
Adobe Illustrator (Version 10 and higher)• 
ACDSystems Canvas (Version X and higher)• 
CiEBV Photoline 32 (Version 11.52 and higher)• 
Corel Painter (Version 9 and higher)• 
LemkeSoft GraphicConverter (Version 5.7 and higher)• 
Macromedia Fireworks (Version 7 (MX 2004) and higher)

... and probably other graphics applications that support Photoshop plugins.

• 

You need one of the following applications to use the Windows version:

Adobe Photoshop (Version 3 and higher)• 
Adobe Photoshop Elements• 
Adobe PhotoDeluxe• 
Adobe After Effects (Version 4.1 and higher, but not animatable)• 
Adobe Illustrator (Version 7 and higher)• 
Adobe ImageReady (Version 2 and higher)• 
ACD Photo Canvas (Version 2 and higher) (Delivered with some editions of ACDSee)• 
ACD Photo Editor (Version 3 and higher) (Delivered with some editions of ACDSee)• 
ACD Canvas X• 
Aurora Borealis Mandala Painter (Version 3 and higher)• 
CADlink SignLab (Version 5 and higher)• 
CDH Image Explorer Pro (Version 4 and higher)• 
CiEBV Photoline 32 (Version 5 and higher)• 
Corel Draw (Version 6 and higher)• 
Corel Paint Shop Pro (Version 10 and higher)• 
Corel PhotoPaint (Version 9 and higher)• 
Corel Bryce (Version 4 and higher)• 
Corel/Metacreations Painter (Version 6 and higher)• 
Deneba Canvas  (Version 6 and higher)• 
Discreet Combustion (Version 2 and higher, but not animatable and preview is blueish)• 
Equilibrium DeBabelizer Pro (Version 5 and higher)• 
GIMP (Version 1.2.4 and higher with the PSPI plugin) (Preview doesn't work correctly and may crash if you scroll
it too often , no color selection dialogs)

• 

Image Analyzer (with the 8bf Interface plugin) (Freeware from http://meesoft.logicnet.dk/)• 
imageN (Freeware from www.pixoid.com)• 
IrfanView (Version 3.85 and higher, Freeware from www.irfanview.com)• 
Jasc Paint Shop Pro (Version 4.12 and higher)• 
KnowledgeAdventure HyperStudio (Version 4.2 and higher, but no color selection dialogs)• 
Macromedia Freehand (Version 7 and higher)• 
Macromedia Fireworks (Version 2 and higher, but transparency isn't correctly displayed in the preview)• 
Magix Xtreme Photo Designer (Version 6 and higher, but applying the plugin to a selection or object causes
problems and sometimes random crashes occur, Freeware from
http://www.magix.com/us/free−downloads/free−software/xtreme−photo−designer/)

• 

Mediachance PhotoBrush (But no color selection dialogs)• 
Megalux Ultimate Paint (Version 2 and higher)• 
Megalux Ultimate FX (Freeware that is not developed anymore)• 
Microfrontier Digital Darkroom (Version 1.2 and higher)• 
Micrografx Picture Publisher (Version 8 and higher, but the preview zoom won't work)• 
Microsoft Image Composer (Version 1.5 and higher, but dragging the preview isn't possible)• 
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Microsoft PhotoDraw 2000• 
Microsoft Picture It! Digital Image Pro (Version 7 and higher, but a 100% zoom may not work correctly and
Cancel sometimes produces a crash)

• 

Newave Chaos Fx: Twilight'76 (Version 1.2 and higher)• 
New World Focus PhotoEditor (Version 4 and higher)• 
Picmaster (Version 1.25 and higher)• 
Plugin Commander Pro (Version 1.5 and higher)• 
PluginMaster• 
PhotoFiltre Studio (Version 7 and higher)• 
QFX / QFX LE (Version 7 and higher)• 
Right Hemisphere Deep Paint• 
Satori PhotoXL (Version 2.29 and higher)• 
Serif PhotoPlus (Version 6 and higher) (Version 6 is freeware from www.freeserifsoftware.com)• 
SigmaPi Pixopedia 24 (Version 1.0.5 and higher)• 
SigmaPi NiGulp (Version 1.5 and higher) (Freeware from http://www.sigmapi−design.com/freeware.htm)• 
Stoik ImageMan Pro (Version 5 and higher)• 
ThinkTank Ameri−Imager (Version 2 and higher)• 
Ulead Gif Animator (Version 4 and higher)• 
Ulead PhotoImpact (Version 4 and higher)• 
VCW Vicman's Photo Editor (Version 6.9 and higher, but preview dragging causes crash) (Freeware from
www.photo−editor.net)

• 

WebSuperGoo Achroma• 
Xara X• 
XnView (Version 1.70 and higher) (Freeware from www.xnview.com)

It hasn't been tested, but should work with:

Ability PhotoPaint Studio♦ 
Adobe PageMaker (Version 6 and higher)♦ 
Adobe LiveMotion♦ 
BananaSoft TwistedPixel♦ 
CADlink SignLab (Version 5 and higher)♦ 
Corel/MetaCreations Painter 5.5♦ 
Corel/MetaCreations Art Dabbler♦ 
Corel Photo House (Version 2 and higher)♦ 
Corel Xara 2♦ 
DigisoftDirect ImagePro 2K1♦ 
Equilibrium DeBabelizer Pro (Version 4.5)♦ 
Fractal Design Detailer♦ 
Macromedia Director (Version 6 and higher)♦ 
MGI PhotoSuite (Version 4 or higher)♦ 
Newtek Lightwave (Version 5.6 or higher)♦ 
Newtek Inspire 3D♦ 
Newtek Aura (Version 2 and higher, but probably not animatable)♦ 
PM Imagic♦ 
Ulead PhotoExpress (Version 2 and higher)♦ 

It does not work with:
Adobe ImageStyler (Doesn't support filter plugins)♦ 
Adobe Premiere (Up to Version 5.1: Renders only black to image)♦ 
ArcSoft PhotoStudio 2000 (Up to Version 4.1: Does not support PhotoShop plugins)♦ 
Datatech ImageMan (crashes when dragging preview and crashes when applying effect)♦ 
FixFoto (Up to Version 2.74: Preview is segmented and final result contains an overlayed thumbnail)♦ 
discreet 3D Studio MAX (Up to Version 4.2: Background image isn't displayed; Color selection dialog
doesn't work; Renders a distorted red/green pattern)

♦ 

Macromedia xRes (Crashes on loading plugin)♦ 
Metacreations Painter 5 (Everything works except final rendering)♦ 
Microsoft Image Composer 1.0 (Does not recognize the plugin)♦ 
SPG ColorWorks: Web (Up to Version 4: Everything works except final rendering)♦ 

• 

LightMachine Manual 5

http://www.freeserifsoftware.com
http://www.sigmapi-design.com/freeware.htm
http://www.photo-editor.net/
http://www.xnview.com/


Installation

Under Windows

Method 1: Using Plugin Installer

In the installation program you will arrive at the "Choose Destination Location" dialog after some time. Here you can enter
the location where the LightMachine files will be installed. If you want to use the Plugin Installer tool later, you can keep
the installation path that is suggested by the installer.

At the end of the installation the Plugin Installer window will appear and display a list of compatible applications that is
installed on your computer. The list may not be as long as the one in the screen shot above, but there should be at least
one application mentioned. The application at the top of the list is always activated. If you want to install LightMachine into
other applications, you should activate them, too. Then please press the Install button to copy the LightMachine plugin
into the plugin folder of the selected application(s). Finally leave Plugin Installer with the Exit button.
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If you install a new application and want to use LightMachine with it, please run Plugin Installer again from the Start >
Program > LightMachine menu and repeat the steps mentioned above.

If your application should not be listed in Plugin Installer or if Plugin Installer terminates telling you that it didn't manage to
find an application, we suggest that you try Method 2 below.

Method 2: Without Plugin Installer

Method 1 is usually the most convenient way of installing LightMachine. But some people keep their plugins in folders
outside an application's plugin folder or some people use an application that is not recognized by the Plugin Installer tool.
In this case you can choose another folder in the "Choose Destination Location" dialog during installation and ignore the
Plugin Installer by closing it with the Exit button.

If you are unsure which folder to choose in the "Choose Destination Location" dialog please see the general installation
instructions below.

Under MacOS X

When installing LightMachine for MacOS X you need to choose the plugins folder of your graphics application. For
Photoshop that would be the Plug−Ins sub folder inside the Photoshop folder. If you are unsure which folder to
chooseduring installation, please see the general installation instructions below.

General Installation Instructions

The following instructions can be used if there were problems during the LightMachine installation.

Adobe Photoshop / Photoshop Elements / Illustrator / ImageReady

Make sure you install the plugin into the "Plugins" or "Plug−ins" sub folder inside the Photoshop, Illustrator or ImageReady
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folder. We recommend that you create a sub folder called LightMachine in that folder and install it there. After restarting
the application, you will find it in the Filter menu.

Adobe PhotoDeluxe

Make sure you install the plugin into the "Plugins" or "Plug−ins" sub folder inside the PhotoDeluxe folder. We recommend
that you create a sub folder called LightMachine in that folder and install it there. After restarting the application, you need
to make PhotoDeluxe display all menu items if you haven't already done that. To display all menu items go to the
Preferences sub menu of the File menu and choose the last item ("Extend Menu" or something similar) on the sub menu
You will find the plugin in the Effects menu.

Adobe PageMaker

Make sure you installed the plugin into Rsrc/.../Plugins/Effects folder inside the PageMaker folder. We recommend that
you create a sub folder called LightMachine in that folder and install it there. After restarting PageMaker, you will find the
plugin in the Element> Image> Photoshop Effects menu.

CiEBV Photoline 32

Choose 'File options' or 'Extended' from the Options menu, click on the 'Plug In Path' tab and select the folder where the
plugin is to be located. After pressing OK, the plugin will appear at the bottom of the Filter menu.

Corel Photo−Paint

Press <Ctl + J> to display the Options dialog, select Plugins from the list box on the left, press the Add button and choose
the location of the plugin. The plugin will appear in the Effects menu right after the Options dialog disappeared.

Corel Photo House

Select Effects > Plug−in Effects > Add/Remove Plugin Effects. Press the Add button and select the folder where the
plugin is located. After pressing OK, the plugin will appear on the Effects > Plugin Effects menu.

Deneba Canvas

Select "Preferences" from the File menu. In the Preferences dialog select the Paint tab. Press the Plug−ins button and
select the folder where the plugin is located. After restarting Canvas, the plugin will appear on the Image > Filter sub
menu

imageN

Select "Plug−ins" from the Configure menu. When the Plugins dialog appears press the Search button. After imageN has
searched all your drives for plugins (which can take some time), the plugin will appear on the plugin list, too. To apply a
plugin, select it from the list and press the Test button.

IrfanView (Version 3.85 and higher)

Make sure that an image is displayed in IrfanView, then select Image > Effects > Adobe 8BF filters. In the appearing
dialog press the "Add 8BF filters" button and choose the folder where you installed the plugin.  It will now appear in the list
on the left. To run the plugin double click on the appropriate item or select it and press the "Start selected filter" button.

Jasc Paintshop Pro 4 − 6

Choose "Preferences" from the File menu, press the Plugin Filters tab and select the folder, where you installed the plugin
from the Plugin Filters tab of the Preferences dialog. After pressing OK, the plugins will appear on the Plugin Filters sub
menu of the Image menu.

Jasc Paint Shop Pro 7

Choose Preferences > File Locations from the File menu, press the Plugin Filters tab and select the folder where you
installed the plugin. After pressing OK, the plugin will appear in the Plugin Filters sub menu of the Effects menu.

Jasc Paint Shop Pro 8 & 9

Choose Preferences > File Locations from the File menu, select Plug−ins from the list box, press the Add button, press
the Browse button and select the folder where you installed the plugin. After pressing OK twice, the plugin will appear in
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the Plugin Filters sub menu of the Effects menu.

Macromedia Freehand

Make sure you install the plugin into the English/Xtras sub folder inside the Freehand folder. We recommend that you
create a sub folder called LightMachine in that folder and install it there. After restarting Freehand, you will find the plugin
in the Xtras menu.

Macromedia Fireworks

Choose "Preferences" from the File menu and activate the Photoshop Plug−ins check box in the Folders section of the
Preferences dialog. Then select the folder, where you installed the plugin by pressing the "..." or Browse button. After
restarting Fireworks the plugins will be displayed at the bottom of the Xtras menu.

Megalux Ultimate Paint

Choose "Preferences" from the Options menu, click on the Plugins tab and select the folder where the plugin is located.
After pressing OK, the plugin will appear in the Adobe sub menu of the Image menu.

Metacreations Painter / Fractal Design Detailer

Choose Preferences > Plugins... from the Edit menu and select the folder where the plugin is located. After restarting
Painter/Detailer, the plugin will appear on the Effects menu.

Microfrontier Color It!

Make sure you install the plugin into the "Plug−ins" sub folder inside the Color It! folder. We recommend that you create a
sub folder called LightMachine in that folder and install it there. After restarting the application, you will find them in the
Filter menu.

Microsoft Photodraw 2000

Select Tools > Options and press the Plugin tab. Press the Browse button and select the folder where the plugin is
located. Finally press OK on the Options dialog. Choose Format > Effects > Plug−ins and select the plugin in the combo
box at the top of the Plug−ins dialog.

Micrografx Picture Publisher

Make sure you install the plugin into the "Plugins" sub folder inside the Picture Publisher folder. We recommend that you
create a sub folder called LightMachine in that folder and install it there. After restarting Picture Publisher you will find the
plugin in the Effects menu.

Right Hemisphere Deep Paint

Select File > Preferences > Directories and press the Browse button next to the Photoshop Plugins text box. In the file
dialog, select the folder where the plugin is located and press OK. Then press OK on the Directories dialog. After
restarting Deep Paint, you will find the plugin in the Filters menu.

SPG Colorworks: WEB

Choose "Preferences" from the File menu and select the folder where you installed the plugin, at the bottom of the
Preferences dialog. After pressing OK the plugin will be accessible from the Plugin Filter Selector dialog which is available
from the Effects menu.

Ulead Photo Impact

Choose "Preferences" from the File menu and select the folder where you installed the plugin, in the Plugins tab of the
Preferences dialog. After restarting Photo Impact the plugin will be displayed in the Photo Wiz category on the Effect
menu.

Ulead Gif Animator

Choose "Preferences" from the File menu, click on the Plugin Filters tab and select the folder where the plugin is located.
After restarting Gif Animator the plugin will appear in the Filters menu.
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Ulead PhotoExpress

Choose "Preferences" from the File menu and select the folder, where you installed the plugin, in the Plug−Ins tab of the
Preferences dialog. After restarting PhotoExpress the plugin will be displayed in the Photo menu.
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Workflow

When correcting photos it is often important in which order you preform certain correction steps. Applying the same
correction steps in a differen order may produce a less good final result.

ColorWasher, LightMachine and FocalBlade

Although our ColorWasher and LightMachine plugins can both adjust color and brightness in images, they do so in a very
different way and produce very different results. Both tools achieve great results in their own respect. The plugins were
created for quite different image processing tasks and complement one another nicely. For some images you will only
need ColorWasher, for some you will only need LightMachine and for others you will need both. FocalBlade provides the
final essential correction tool as it enables you to enhance the clarity of detail, or sharpness, of your photos.

You should use ColorWasher for correcting photos which are completely under or overexposed, as well as those with
overall color cast problems. It lets you correct such images automatically and very quickly. LightMachine, on the other
hand, is needed to make refined adjustments to the specific problem areas in partially under or overexposed photos,
and/or to make sophisticated brightness and contrast corrections.

If you need to use both plug−ins to work on different aspects of the same photo, you should use ColorWasher before you
run LightMachine, otherwise you may worsen or emphasize the color cast when using LightMachine. In such a case
please try to avoid using the Exposure and Highlights/Shadow features in ColorWasher. Manipulating the brightness in
ColorWasher may prevent LightMachine from producing the best results in certain image areas, but first using Auto
Contrast in ColorWasher may help LightMachine achieve a better result. A color shift can become visible after lifting
shadows using LightMachine, but this problem can be dealt with using its features for correcting specific image areas.

While ColorWasher should be used before LightMachine, FocalBlade should ideally be applied only after your color
corrections have been completed. If you use FocalBlade before ColorWasher and LightMachine, it is possible that the
sharpness effect might be increased or decreased, which can result in artefacts.

LightMachine and Other Tools

Correcting the brightness or contrast of a photo with any other tool before using LightMachine is not recommended as this
might detrimentally affect the quality of Light Machine's results.

If preferred, you can also use LightMachine only as a masking tool and do your corrections with other tools. To do this you
can render the mask to the image by activating the N or P button and pressing OK. The resulting B/W mask can then be
used as a layer mask. Alternatively you can run LightMachine on a layer, activate the S or H button and press OK. The
mask will make certain areas of the layer transparent.
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General Usage

Before using LightMachine you have to start your preferred image editing application and open an image or photo. Please
note that LightMachine only works on images in 8bit or 16bit RGB mode. If your image is grayscaled, has only 256 colors
or is a CMYK image, you have to convert it in your image application to RGB before you can start working on it with
LightMachine. If the opened image is not RGB, LightMachine will appear grayed out on the menu.

To run LightMachine please open the menu that leads to the plugin filters (usually the "Filter", "Effects" or "Image −>
Plug−ins" menu) and choose "LightMachine" from the " PhotoWiz" sub menu.

Modes

LightMachine features nine different modes which can be selected from the combo box at the top. There are only four
basic filters (Brightness/Contrast, Shadows/Highlights, Virtual Studio and Colors), but each of them is available in basic
mode as well as Pro mode. As a novice you should start with the basic modes and then try the Pro modes (which allow
more sophisticated corrections) after you have mastered the easier modes. For more information on the various modes,
please read the Modes page.

Basic Design

LightMachine contains three tab sheet controls at the right side of the preview. The first tab sheet offers controls for
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adjusting the brightness, contrast, colors and saturation in the image. The second tab sheet control in the middle contains
controls for adjusting the mask that controls with which intensity the effect is applied to which image area. Finally, the third
tab sheet control at the bottom contains the Help box, the histogram view, the Info tab sheet and the Preferences.

The Preview

On the left−hand side of the dialog box is the preview box that shows you what the final effect will look like. When
executing LightMachine it will always display the full image in the preview. This is also the recommended way to work on
an image. If you zoom into the image, only a part of the image is displayed in the preview. The image can then be moved
by holding down the right mouse button (or pressing the Alt key and holding down the left mouse button) and moving the
mouse. While it is moved, the original image is shown and after you release the left mouse button the preview is
recalculated.

If one of the Spit Views is activated, you can move the separation lines in the preview by holding down the ALT key and
dragging, or you can select one of the split areas by holding down the Shift key and clicking on it. For more information,
please read the Split View page.

Changing the Window Size

You can enlarge the LightMachine preview window to display the image at a larger size in the preview or a larger portion
of the image if you zoom in. However, doing that will also increase the time that LightMachine needs to update the
preview. If you use an old and slow computer, it isn't recommended to enlarge the LightMachine dialog. On the contrary
you can also make it smaller to make LightMachine render the preview faster.

To resize the LightMachine window and make the preview larger under Windows you have to move your cursor to the
border of the LightMachine dialog. The cursor will then turn into a double arrow. Holding down the left mouse button and
dragging the mouse changes the size of the window. Double clicking the LightMachine title at the top left corner will
maximize the window, double clicking them again will restore the old window size. Under MacOS X you need to drag the
handle at the bottom right of the LightMachine dialog.

The Help Text Box

The Help feature makes it easier for new users to get started and makes it possible to use LightMachine without a glance
in the manual. Other than that it can provide useful hints and assist you in the correction process. If you move the mouse
over a certain control, the text box will display some explanations and hints about that control.

After you know all about LightMachine and have mastered the sample area technique, you can deactivate these
explanations by deactivating the check box in the bottom right corner of the Help box. We recommend that you keep it
nevertheless activated.

The Fade Slider

The Fade slider lets you weaken the overall effect of LightMachine. A value of 255 will apply the effect at full strength,
while a value of zero won't change the original image. This slider is useful if you don't want to mess with many other slider
and want to weaken the global effect of LightMachine.

The Zoom Buttons and Zoom Check Box

At the right bottom of the preview box you can see a '+' and '−' button with a percentage label in between. These zoom
buttons let you adjust the size of the image in the preview box. 100% means that the original size of the image is
displayed.
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By default when starting LightMachine, the zoom rate will be automatically set to make the image fit into the preview. If
you hold the Shift key when pressing one of the zoom buttons, the zoom factor will be set to the highest (100%) or lowest
acceptable value (fitted zoom). If you hold the CTRL key when pressing one of the zoom buttons, the zoom factor will be
set to the highest (100%) or lowest possible value (6%). Some very old applications (e.g. Corel Photopaint 7 or Corel Xara
2) don't support preview zooming. In this case the zoom buttons won't work.

To jump from one preview zoom rate to another you can use the zoom combo box which is located between the two
zoom buttons. It also offers the option "Fit" which should be used most of the time.

Auto Preview

If the Auto Preview check box is deactivated, the effect will not be displayed on the preview. Instead you will see the
original image.

Split View & Multiple

LightMachine offers various split views for evaluating or correcting the image. For more information, please read the Split
View page.

The B/W Button

The B/W button displays the image in the preview grayscaled. This can be a help when correcting images.The B/W
button can also be used to convert your images into B/W images. Various other options of LightMachine let you adjust the
B/W look.

Sliders

Sliders can be used to select a certain value within a specific value range. To do that you can drag the slider knob with the
mouse (or keyboard), enter a numerical value in the white text box at the right of the slider bar, click somewhere on the
slider bar for large value steps or use the two arrow buttons for small value steps. Holding the Shift key while dragging
the slider knob, makes the preview update with every movement of the knob.

You can now also use the mouse wheel to change the slider values. You need to give the slider the focus by clicking on it
or using the tab key. After that you can scroll the mouse wheel to move the slider knob. After you stopped moving the
wheel the preview will automatically update.

OK, Cancel and ?

Clicking on the OK button exits LightMachine and applies the effect to the image. The current settings are saved and
restored when you use LightMachine again and have the On Start Up setting activated in Preferences.

The Cancel button simply exits LightMachine without changing the image. Depending on the application you are using,
the current settings will be lost immediately or kept as long as your image application is running. If you hold down the
CTRL key while clicking on Cancel, you will be prompted for Cloak Mode. In Cloak Mode the current settings will be
applied to the image without displaying the LightMachine dialog. For more information, please read the Cloak Mode page.
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Step By Step Guide

Correcting the Whole Image

1. Switch to "Brightness/Contrast Pro" mode with the Mode comb box at the top.

2. Click on the Reset button to undo all previous changes.

3. Adjust the Brightness slider. If blown highlights (uniform white areas) appear, reduce the value of the
Brightness slider.

4. Adjust the Contrast slider. If the value is too high, some areas in the image will become too dark. If
the value is too low, the image will appear too gray.

5. Carefully adjust the Amplify slider if you are not satisfied the effect. You may need to readjust the
Brightness and Contrast slider if you use a too high or low value for the Amplify slidier.

6. If necessary you can use the Local Contrast slider to compensate a low Contrast slider value or to
remove a hazy effect. For that purpose, slowly increase the value of the Local Contrast slider and
observe the effect.

7. Adjust the Radius slider to modify the local contrast effect. Readjust the Local Contrast slider if
necessary.

Correcting Shadows and Highlights

Starting

1. Switch to Shadows/Highlights Pro mode using the Mode combo box at the top.

2. Click on the Reset button to undo all previous changes.

Adjusting brightness and contrast to see the effect

3. Increase the value of the Brightness slider of the Shadows tab sheet until the dark areas in the image
become more visible without getting too bright.
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4. If the shadows look too burnt, try a negative value for the Contrast slider. If they look too gray and flat,
try increasing the contrast.

5. Carefully adjust the Amplify slider if you are not satisfied with the effect. You may need to readjust the
Brightness and Contrast sliders if you use too high or low a value for the Amplify slider.

Using Auto Mask for adjusting the shadow mask (Skip to step 11 if you want)

6. Start with the "Very Deep" setting in the Shadow Depth combo box of the Auto Mask tab sheet. Try
the various Shadow Depth settings to see which best reveals the shadow areas without brightening the
highlight areas.

7. Choose "Low Contrast" or "High Contrast" from the Image Type combo box. Depending on which
setting you choose the next combo box will be called "Shadow Shift" or "Anti−Alias".

8. Choose one of the settings from the Shadow Depth or Anti−Halo combo box. If you choose too high
an option for Shadow Depth the borders between the shadow and highlight areas might be too dark.
"Method 2" in the Anti−Halo combo box effectively reduces halos, but can have a negative impact on the
appearance of some images. If that's the case, try Method 1. If there are no improvements, turn
Anti−Halo "Off".

9. Starting with the "Very Fine" setting in the Details combo box, cycle through the options to find which
produces the best results for your image.

10. Try all options from the Color Filter combo box. "Green" will work well in many casesby removing
greenish areas from the shadows and adding them to the highlights. If you want to add green areas in
the image to the shadows, please select its opposite color "Magenta". Other images may need another
color filter.

Fine−tuning the mask (Skip to step 19 if Auto Mask worked perfectly)

11. The Auto Mask tab sheet is a good place to start for adjusting the shadow mask, but in some cases
you will need to switch to the Fine−Tune tab (see step 18) to improve the mask even more. Tip: Clicking
on the label of one of the Auto Mask features, will switch the focus to its combo box. You can use the
Tab key to switch between the Auto Mask combo boxes − Tab will move you down one box, Shift+Tab
will move you up one box. Use the left and right arrow keys to move up and down through the options in
the combo boxes.

12. If necessary use the Threshold slider to define the border between the shadows and highlights even
more precisely.
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13. Keep the Range slider to zero unless you want to partially affect the highlights with the shadow
correction, too. That is usually necessary for images that don't have strict shadow/highlight borders.

14. The Shift slider lets you shrink the shadow areas to create a smoother transition between shadows
and highlights or to reduce halos. Lower values usually work best.

15. The Anti−Halo slider is for reducing halos in case the Shift slider doesn't help. However, it can also
reduce the quality of the correction, so use with care.

16. The Radius slider has an effect on the size of a halo and the diffusion of the light. It can also be used
to create a smoother transition between shadows and highlights.

17. The Color Filter slider lets you exclude or include image areas of a specific color from the shadows
or highlights. Setting it to a green value will exclude green objects from the shadows and include
magenta ones in the shadows. At the same time it will include green objects in the highlights and
exclude magenta objects from the shadows. The same is true for all other colors and their opposing
colors.

18. Try the N, P, S and H buttons to see the mask that you have created. Having one of them activated
while adjusting the mask can be helpful.

Readjusting the effect

19. After you have followed these steps you may want to readjust the Brightness and Contrast sliders on
the Shadows tab again.

20. If the shadows have been brightened too much, the edges of image objects may appear too flat. You
should be able to recover these details with the Local Contrast and Radius sliders. In other cases better
results can be achieved by using lower values in the Contrast slider to reveal more darkened areas and
adjusting the Local Contrast slider to add back contrast.

21. If you notice that the lifted shadow areas have a color cast, please switch to the S−Color tab and try
the four sliders at the top. If the shadow areas contain an almost gray or white area, try the following:
Click on the A button and then click on the almost gray or white area in the shadows. If that doesn't
work, try again or Shift click the S−Color tab button to reset the controls of the S−Color tab.

22. Adjust the Saturation slider if the shadows look too gray or too colorful. Try the other options of the
combo box on the left of the slider to avoid color noise or oversaturation.

Correcting the Highlights

23. Some images may require that you also adjust the highlights to make them better match the lifted
shadows or to make them less bright or faded.

24. Switch to the Highlight tab sheet and use the brightness, contrast, color and saturation controls as
you used them for correcting the shadows.

Using Virtual Studio Mode

Starting

1. Switch to Virtual Studio Pro mode with the Mode combo box at the top.
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2. Click on the Reset button to undo all previous changes.

Adjusting Brightness and Moving the Spot

3. Increase the value of the Brightness slider of the Spots tab sheet until the default spot in the image
becomes visible without getting too bright. Because the Brightness slides affects ALL spots, Brightness
should always be set for the brightest spot. Less bright spots can be achieved by selecting each spot
and adjusting the Intensity slider. Please see point 11.

4. Click on the cross of the spot and drag the spot to a place on the image that you want to change.

Adjusting the Spot

5. If you want to create a shadow spot instead of a light spot, please use a negative value for the
Intensity slider on the Spot Mask tab sheet.

6. Adjust the Size slider until the spot has the right size.

7. Adjust the Ovality slider if you want to spot to only cover an oval area. After that use the Angle slider
to rotate the spot if necessary.

8. Adjust the Hardness slider to make the center of the spot brighter. You may want to readjust the
Brightness or Intensity slider after that.

9. Use the Reflection slider to make the spot less or more bright on certain image areas. If the spot
produces halos, reduce the value of the Reflection slider or use the Shift and Ant−Halo sliders from the
Reflection tab sheet. You can fine−tune the reflection properties of all spots even more on the Reflection
tab sheet.

Creating a New Spot (Skip steps 10 to 12 if you don't want a new spot)

10. If you want to add another spot, please click on the image in the preview where you want to have it.
When you add a new spot, it will have the same properties as the last spot created or adjusted.

11. Adjust the Intensity slider on the Spot Mask tab sheet if you want to have the spot less bright than
the previous spot. If you want to have the current spot brighter, please increase the value of the
Brightness slider. Please see step 3.

12. Repeat steps 5 to 9.

Readjusting the General Effect

13. After you have created as many spots as you need, you can simultaneously readjust the brightness
of all these spots with the Brightness slider on the Spots tab sheet.

14. Try the other sliders on the Spots tab sheet as well as the sliders on the S−Color tab sheet.

15. You may also want to readjust the reflection effect on the Reflection tab sheet.
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Correcting the Background

16. For some images you may also want to adjust the area outside the spots. That can be done with the
controls on the Back and B−Color tab sheets.

Changing the Color of an Image Object

1. Switch to Colors Pro mode with the Mode combo box at the top.

2. Click on the Reset button to undo all previous changes.

3. In the preview please click on the object in the image that you want to colorize. Please click again on
another area if you want to include it as well. Shift click an image area to remove it again.

4. Switch to the Colors and C−Color tab sheets and adjust selected image area as you wish.

5. If the image object or areas aren't corrected or colored as you want it to, there are several
possibilities. You can use the Impact slider from the Color Mask tab sheet to intensify the effect.
Additionally you can set the Brightness, Contrast, Adjust, Red, Green, Blue and Saturation sliders to
more drastical values.

6. If necessary, switch to the Back and B−Color tab sheets and adjust the background areas.

Selective B/W Effects

Making the whole Image B/W with the exception of one or two colors

1. Switch to "Color Replace" mode with the Mode comb box at the top.

2. Click on the Reset button to undo all previous changes.

3. Set the Saturation slider from the C−Color tab sheet to −100.

4. Activate the "Invert" check box from the Color Mask tab sheet.

5. Click on the color in the preview that you want to keep colored.

6. The image will now appear B/W with the exception of the areas with the selected color.

7. Use the Impact slider to make the colored area stand out better.

8. If you want to keep another color, click again on a new color in the preview. If you want to remove one
color and make it B/W again, hold down the shift key and click on it in the preview.

9. Again try using the Impact slider to emphasize the new colored area if necessary.

10. You can adjust the B/W effect by choosing another option from the Saturation combo box or by
using the Adjust, Red, Green and Blue sliders from the Color tab sheet.
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Making the one or two colors in the image B/W

1. Switch to "Color Replace" mode with the Mode combo box at the top.

2. Click on the Reset button to undo all previous changes.

3. Set the Saturation slider from the C−Color tab sheet to −100.

4. Click on the color in the preview that you want to make B/W.

5. The color will now appear almost B/W in the preview.

6. Use the Impact slider to intensify the B/W effect.

7. If you want to make another color B/W, click again on a new color in the preview. If you want to make
that area colored again, hold down the shift key and click on it in the preview.

8. Again try using the Impact slider to intensify the B/W effect if necessary.

9. You can variate the B/W effect by choosing another option from the Saturation combo box or by using
the Adjust, Red, Green and Blue sliders from the Color tab sheet.

Using LightMachine as a Masking Tool

Obtaining the shadows and highlights as separate transparent layers

1. Duplicate the image on a new layer in your graphics application.

2. Run LightMachine.

3. Adjust the sliders in LightMachine as you wish to create a certain mask.

4. Activate the S button and press OK. As a result you will have the shadow areas on a layer. All other
image areas have become transparent.

5. For receiving the highlight areas on another layer please repeat step 1 to 4, but use the H button in
step 4.

6. Please keep the original background image, because some areas may be transparent on both
shadows and highlight layers.

7. Now you can selectively adjust the shadows and highlight layers with the tools of your graphics
application or with other plugins. You can also use LightMachine's Brightness/Contrast (Pro) mode on
both layers.

Using the LightMachine mask as a layer mask

1. Duplicate the image on a new layer in your graphics application.

2. Run LightMachine.

3. Adjust the sliders in LightMachine as you wish to create a certain mask.

4. Activate the P button in LightMachine and press OK. That will give you the shadow/highlight mask as
a B/W image on the layer.
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5. Now you can use the LightMachine mask as a layer mask by again duplicating the image as a new
layer, adding a layer mask and copying the LightMachine mask into the layer mask channel.

6. Now you can selectively adjust the image with the tools of your graphics application or with other
plugins. You can also still use LightMachine's Brightness/Contrast (Pro) mode.
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Tips for Tough Cases

Tip 1 − Don't Increase Brightness Too Much

Although it may be seductive to set a high Brightness value in LightMachine, you can easily overdo it. If the dark areas of
an image are brightened up too much, they will lose contrast and look unnatural.

Tip 2 − Think Simple

A good Brightness and Contrast value should be chosen before you start tweaking the mask options in
"Shadows/Highlights Pro" or "Virtual Studio Pro" modes. It can help to switch to the simple "Brightness/Contrast" or
"Brightness/Contrast Pro" mode and concentrate on the brightness and contrast controls alone. In these modes the whole
image will be affected, so you can see what would happen to the image parts, and which are already correctly exposed,
without a mask.

Tip 3 − Push the Contrast

Image areas that are brightened up easily lose contrast in the details. You can compensate for this loss by using the Local
Contrast slider. Sometimes you can even achieve better results by lowering the Contrast slider to make more details
visible, although they may appear more flat.  You can then increase the Local Contrast slider to regain the lost contrast .

Tip 4 − Start With Auto Mask

The Auto Mask options can be a good starting place when correcting an image. The Auto Mask combo boxes demand
only a few simple choices from you, so you can adjust the mask for the current image very quickly. For tough cases you
will have to additionally switch to the Fine−Tune mode and slightly adjust the sliders there.

Tip 5 − Try Virtual Studio as an Alternative

For a some images the Shadows/Highlight modes only produce half−satisfying results. In such cases you can often
achieve superior results by using Virtual Studio mode to place spot lights over the objects that need to be brightened.

Tip 6 − Avoiding Noise

If lifting shadow areas with LightMachine results in visible noise, you can use a third−party noise reduction tool to remove
it. An alternative is to reduce the brightness in the shadows to make the noise less visible. Also, please remember that
low−cost cameras are more likely to produce noise in the shadows. Setting your camera to its highest quality setting (for
less JPG compression) can avoid unnecessary noise in the shadows.

Tip 7 − Sleep On it and Try Again the Next Day

Sometimes when you are very enthusiastic or in a hurry to correct a photo, you might do a correction that isn't that
brilliant. If you have the time, it sometimes helps to leave a photo alone and to try correcting it again the next day. You
might find that you missed something the day before or produced a too extreme correction.
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Monitor Calibration

Calibrating your monitor is quite important if you want to do serious photo correction on your computer. If you have
wondered why your photos come too bright or dark out of the printer or from your photo service after you corrected them,
you should consider calibrating your monitor. A good calibrated monitor isn't absolutely necessary for using LightMachine,
but it is recommended.

Calibrating a monitor can be a longer lasting process. Usually you think that you calibrated the monitor correctly after
going through some complex procedures. But some hours or days later you might find it unsatisfactory, because you
adapted to its color temperature and recognize a color cast that you didn't see before, or your eye may begin to burn,
because the monitor's display is too bright. Then it is time to readjust or recalibrate the monitor or your system gamma.
Don't be surprised if you need to do that more than just two times :−).

Monitor Brightness &Contrast

You should set brightness and contrast with your monitor's knobs to values that don't strain your eyes too much. Here are
some recommended values which vary between individual and display device:

Recommended
Monitor Values

CRT
Monitor

TFT Monitor
with RGB Input

TFT Monitor
with DVI−Input

Contrast 100% 30 − 50% 10 − 30%

Brightness 10 − 50% 10 − 75% 10 − 50%

The Monitor Brightness and Monitor Contrast also shouldn't be set to extreme levels, otherwise the colors might be
displayed a bit washed out or too saturated. But above all they are not so important, because calibrating your system for
the optimal gamma doesn't depend on the monitor's brightness and contrast. However, you still use one of the white and
black patterns from the URLs below when adjusting your monitor's brightness and contrast.

Please note: If you readjust the brightness or contrast of your monitor later, you should recalibrate the system gamma.

Links:

The following URL describes how to accurately adjust the brightness and contrast on your CRT monitor.
There are other calibration resources on the same site, too.
http://www.aim−dtp.net/aim/calibration/blackpoint/crt_brightness_and_contrast.htm

Here are some calibration patterns and instructions:
http://desktoppub.about.com/library/weekly/aa070102a.htm
http://www.mindspring.com/~woharris/cal.htm
http://www.dramainnature.com/monitor_calibration.htm
http://www.lunnfabrics.com/monitor.htm

Monitor Color Temperature or RGB Values

Several monitors let you set their color temperature. Often you are offered 6500 Kelvin or 9300 Kelvin. At 9300 Kelvin
your monitor already displays the colors too blueish, while at 6500 Kelvin there will be a bit too much yellow present. If
you don't have an option in between or can't set a custom value, please use 6500 Kelvin.

I you have the option to set your monitor's RGB balance, then try that. Make sure that you have an image with a lot of
gray or white tones displayed or simply an application with a gray colored background (but not the yellowish gray of
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Windows 2000 and XP!). Firstly set all R, G and B values to a similar value, e.g. 50%. If you see a certain color cast on
the gray or white image, use the R,G and B knobs to remove it.

Please note: If you readjust the brightness or contrast of your monitor later, you should recalibrate the system gamma.

Calibration with a Print

A crude but some times effective method for adjusting the brightness of your monitor is to print a photo with your printer or
to order a print from your preferred photo service and to use that print for adjusting the brightness setting of the monitor.
Makes sure that there is a similar light as you usually have when working on the computer.

Gamma

Some applications like Paint Shop Pro offer a "Monitor Gamma" option. First of all, the term is incorrect and should be
called "Application Gamma" and secondly these options only display the images at the selected gamma within that
application. Using such an application−dependant gamma makes no sense and leads to confusion, because when you
display the same image in a different application, e.g. you browser, it might look totally different.

What you should use is a system−wide gamma adjustment. If your monitor already includes an ICC profile on a
CD−ROM, you should install it. You can also manually add it under Start > Settings > Control Panel > Display > Settings >
Advanced > Color Management. After doing that you may need to change the brightness setting of your monitor again as
described above.

Otherwise you can also the gamma feature that the drivers of some video cards offer. If you only installed the standard
Windows drivers of your video card, please install the ones from the video card's manufacturer. That might give you such
a feature. However, the gamma feature should also contain interlaced patterns for adjusting the optimum gamma. Various
patterns are available on the Internet if you miss one. See below. To adjust the gamma you usually have to close your
eyes a bit or move away from the monitor to see the pattern(s) a bit blurred. I know it can be tiring to keep your eye lid that
way or stretch yourself to still reach the mouse, but that's the price :−).

As an alternative to your video card's gamma feature you can also use an application to create an ICM profile for your
monitor. A good tool for this purpose is the Adobe Gamma control panel which is installed with Adobe Photoshop. If you
don't own Adobe Photoshop, you can try to download a demo version of it and install it. Adobe Gamma contains a wizard
which leads you thought the calibration process and automatically activates the generated ICM profile.

Please notice: If you exchange your video card or monitor later, you should recalibrate the system gamma.

Links:

How to use Adobe Gamma:
http://www.ephotozine.com/techniques/viewtechnique.cfm/recid/12

Some gamma patterns and explanations can be found at the following address. But please ignore the
comments about setting your system default system gamma to 1.8 or 2.0. That is not necessary to get a
good calibrated monitor.
http://www.photoscientia.co.uk/Gamma.htm

Here are some more gamma calibration patterns:
http://epaperpress.com/monitorcal/
http://desktoppub.about.com/library/weekly/aa070102a.htm

Special Calibration Devices

The must reliable way to calibrate your monitor is to use a hardware device that is placed on the monitor for measuring
colors and brightness. This approach is especially recommended for TFT monitors as they have more problems with
displaying color correctly than CRT monitors. For example the Spyder calibration device from Colorvision is already
available for $150.
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Links:

Colorvision Spyder:
http://www.colorvision.com

Printer Calibration

If you use a professional photo service, you don't need to worry much about printer calibration. But if you want to print
your photos with your own printer, this can be an issue. Printer drivers are usually already calibrated for the inks and
papers of the printer manufacturer. If you use other inks and papers, you may need to calibrate your printer. There are
some companies that sell printer profiles, so that you don't need to calibrate your printer yourself. But as these profiles are
only calibrated for certain cases, you may have no luck when using them. For an accurate printer calibration you will also
need a hardware device that measures the colors and brightness of a print.
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Key Shortcuts

ColorWasher lets you use a few key shortcuts for performing certain tasks. Professional computer users usually prefer to
use key shortcuts as they help to achieve some tasks much faster. The shortcuts available are indicated by an underlined
letter in the button label. Here is a list of all shortcuts that can be used in LightMachine:

Key Shortcut Explanation

CTRL and O (Windows only) Displays the Open Preset dialog

CTRL and S (Windows only) Displays the Save Preset dialog

CTRL and Z (Windows only) Performs Undo or Redo

ALT and M (Windows only) Activates or deactivates the Multiple check box

ALT and P
(Windows only) Activates or deactivates the Auto Preview check
box

ALT and R (Windows only) Resets some controls to their default values

ALT and W (Windows only) Activates or deactivates the B/W Mode

ALT and + (Windows only) Increases the preview zoom ratio

ALT and − (Windows only) Decreases the preview zoom ratio

ALT and ? (Windows only) Displays the manual

B
(When the mouse is placed over the preview) Displays a page
with photos of the beta testers.

Del / Backspace In Virtual Studio Mode: Delete spot

1 − 9, 0 In Virtual Studio Mode: Select a spot Nr. 1 to 10.

Up, Down, Left or
Right

In Virtual Studio Mode: Move spot by 10 pixel

CRTL + Up, Down,
Left or Right

In Virtual Studio Mode: Move spot by 100 pixel
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Modes

Although there are only four primary filters in LightMachine (Brightness/Contrast, Shadows/Highlights, Virtual Studio and
Colors), they are split up into 9 different modes to make it easier for beginners to learn to use LightMachine. The basic
modes are recommended for beginners, because they offer only the more important controls. As you get to know
LightMachine more and more you should try the Pro modes, too. The Shadow/Highlight Pro, Virtual Studio Pro and Colors
Pro are the main modes of LightMachine, offer the most controls and let you achieve the best results.

Switching Modes

The different modes in Lightmachine work as seperate filters. If you change to another mode, the effect from the previous
mode is replaced by the effect of the new mode. If you want to apply two different modes to the same images, you have to
press OK to apply the adjustments of the current mode and then run LightMachine again to apply the effect of another
mode.

When switching modes several slider values (especially those of the upper tab sheets) are carried over from the previous
mode, which can be a big help if you want to try different modes on the same image. There two avenues when switching
modes that are useful:

Brightness/Contrast (Pro) −> Shadwos/Highlights (Pro) −> Virtual Studio (Pro)

Color −> Color Replace −> Color Pro

You can ignore the middle mode or last mode or start with the second mode or jump from a basic mode to a Pro mode as
long as you don't leave one of the two paths. However, it makes not so much sense switching between modes like Color
Replace and Shadow/Highlights Pro, because one mode targets the colors of colored objects while the other mainly
targets the brightness of dark or bright objects. So you have to expect that the same color and brightness values have a
different effect in both modes. Of course, it can be done and may be needed in some cases, but you have to expect to
heavily readjust the controls then.

The layout of the Mode combo box represents these two paths, so that you probably use them intuitively.

Brightness/Contrast

This mode just offers a Brightness and Contrast slider. They work much better on photos than the brightness and contrast
sliders that can be found in many graphics applications. For more explanations, please read the Brightness/Contrast
page.

Shadows/Highlights

The Shadows/Highlights mode offers only the most essential controls for independently adjusting the shadows and
highlights in the image.

Virtual Studio

The Virtual Studio mode offers most controls of the Virtual Studio Pro mode, especially the sophisticated Reflection
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features. So it is more suitable for artistic light effects. It lets you place an unlimited number of light spots as well as
shadow shots all over the image by clicking on the preview. You can also select existing spots by clicking on their cross
and move them to another position by dragging them.

Brightness/Contrast Pro

In addition to a Brightness and Contrast slider, this mode also offers two sliders for adjusting local contrast. It is helpful for
images that need a strong contrast increase and the normal Contrast slider doesn't help anymore.  For more
explanations, please read the Brightness/Contrast page.

Shadows/Highlights Pro

The Shadows/Highlights Pro mode is the most flexible mode for correcting photos with shadow and highlight problems.
The huge amount of controls offer even more possibilities and lets you correct as good as any type of photo.

Virtual Studio Pro

In Virtual Studio Pro you can feel like in a real photo studio, but unlike the real thing you have unlimited light spots that
you can arrange. Additionally you can also place shadow spots on the image to remove the light from certain areas. The
Reflection features adapt the spots to the shape of the objects in the image and avoid blown highlights. You can create
these spots by clicking on the preview. You can also select existing spots by clicking on their cross and you can move
them to another position by dragging them.

The Brightness and Contrast sliders work on all spots simultanously, so they are for general adjustments. You have to set
them for the brightest spot and reduce the Intensity slider for all spots that should appear less bright. Same is true for the
color and saturation sliders.

Colors

Lets you adjust the brightness and contrast of image objects with a certain color. To select a color you just need to click
on the preview. To deselect it again please shift click on the same color in the preview.

Color Replace

Color Replace is a specialized version of the Colors Pro mode. It is intended for selectively adjusting the color of image
objects with a certain color. To select a color you just need to click on the preview. To deselect it again please shift click
on the same color in the preview.

Colors Pro

Lets you adjust the brightness, contrast, color and saturation of image objects with a certain color. To select a color you
just need to click on the preview. To deselect it again please shift click on the same color in the preview.
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Reset, Undo &Presets

Reset

When you want to undo the current correction settings, you can click on the Reset button. This is helpful if you want to
undo a correction or when you start with a new image. The behavior of the Reset button can be defined by the On Reset
combo box on the Prefs tab sheet. For more information, please read the Prefs Tab page.

Right clicking (or CTRL−clicking on the Mac) on the Reset button will display a context menu with various options. The
four options correspond to the options of the On Reset combo box of the Prefs tab: "Default Settings" activates the default
setting and removes any adjustments that you made. ""Preview Settings" loads the settings that were used for correcting
the previous image. "Own Defaults" will automatically open the preset file that you have chosen when selecting the "Own
Default" in the Prefs tab. "Logged Settings" will open a preset that was automatically saved when you corrected the same
image the last time, provided that you had the Log Settings check box in the Prefs tab activated.

If you want to reset only the controls of a certain tab sheet, you can do that by holding down the Shift key and clicking on
the tab button.

Top Button Menu

If you click on the small icon at the left of the Mode combo box, a menu will be displayed. This menu includes options for
opening and saving presets, an Undo/Redo feature and a list of all presets from the Preset sub folder of the LightMachine
folder.

Open Presets

Several presets are already delivered with LightMachine. They only deliver rough values, but they may be useful as a
starting point for a manual color correction or artistic effect.

Save Preset

You can save a preset by using the Save Preset option. Please save presets into the Presets sub folder within the
LightMachine folder as that is the location where LightMachine looks for them. You can open a preset later again with the
Open Preset menu item.
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Undo / Redo

The Undo / Redo option will restore the control settings that were used before the preview was updated, because you
changed a slider value, pressed a button or moved a spot light. If you didn't do any changes to the LightMachine settings
and select this command a second time, it will peform a Redo and restore the settings that were used before you used the
Undo / Redo command for the first time.
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Split View

The various split views let you evaluate certain aspects of the image or perform a certain photo correction.

Using Left, Right, Bottom and Top View

These four split views let you compare the original image with the corrected version side by side. The corrected image will
be displayed at the left, right, top or bottom as the names indicate. To move the separation line between the two versions,
hold down the ALT key and drag on the preview. If you have Instant Preview from the Prefs tab sheet activated, the effect
of moving the separation line will be immediately visible.

Multiple

The Multiple check box only work in combination with the Split View options. If it is activated you will see the same image
content in each split view area. You can click somewhere to display a different part of the image in both split areas. If the
Instant Preview check box from the Prefs tab sheet is active, you can alternatively hold down the Alt key and drag over
the preview to make it move. If Instant Preview is switched off, it makes no sense to drag, because you won't see anything
moving.

There is one things that you should also know about Multiple mode. If you activate the Multiple check box in Virtual Studio
(Pro) mode, the spot crosses will disappear and you will not be able to edit the spots. To edit the spots or add new ones
you need to deactivate the Multiple check box.
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Histo Tab

Basically histograms don't show anything you can't see in the image itself if you know where to look and look really
closely. But histograms have the advantage that they are more structured than the image itself, so they let you recognize
image problems easier.

A histogram is a statistical display of an image parameter, e.g. brightness, hues or saturation. It shows the distribution of
certain pixel values in an image. These values usually range from 0 to 255 in a 8bit image. The range of these values is
displayed from left to right in the histogram, so the value 0 is displayed at the outer left and the value 255 is displayed on
the outer right side. The amount of each value is displayed from bottom to top, so the height of the curve represents the
number of pixels that have a certain value. If more pixels have a certain value, the histogram curve will be higher at that
point.

In LightMachine the histogram curve is separate into three areas: the shadows on the left side (with values from 0 to 85),
the midtones in the middle (with values from 86 to 170) and the highlights at the right side (with values from 171 to 255).
LightMachine displays all three areas equally wide, although some people may argue that the midtones are double as
wide as the shadows and the highlights. But usually it more useful to define the three areas equally wide.

Peak, Mean, Shadows, Midtones and Highlights labels

The Peak figure lets you know which brightness, color or other value occurs most often in the image. The histogram curve
usually has its peak at that value. The Mean figure tells you the average brightness, color or other value. If this value is
below 128, the image contains e.g. more dark then bright areas.

The Shadows percentage lets you know how much of the image is in the lower value range (e.g. is quite dark), the
Midtones figure tells you how much of the image is in the middle range (e.g. is moderately bright) and the Highlights
percentage shows you how much of the image is in the upper range (e.g. is bright). For example if the Shadows
percentage in the RGB or Intensity histogram is very high, it can mean that the photo is underexposed.

RGB Histogram

You can use the RGB histogram to see if there are blown highlights or cutoff shadows in an image. Blown highlights can
be identified by a high spike at the right side whereas cutoff shadows are represented by a high spike at the left side. The
higher and wider the spike is, the more information was cut off.
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If there is large slope on the left or right side and not just a thin spike, then the photos is already quite damaged. Another
bad sign is if the middle part of the curve is quite flat or extremely ducked to the ground. If such histograms are produced
by a correction you did in LightMachine, you should correct your adjustment.

The RGB histogram also shows the darkest value (the end point of the curve at the left) and brightest value (the end point
of the curve at the right) in an image. Both are also called black point and white point. The range between both points is
called dynamic or tonal range and determines the contrast of the image. The optimal contrast is achieved if the curve
starts at the outer left and ends at the outer right. If that isn't the case, the image may not have a good contrast. If the
curve starts too more towards the middle, it also means that the image is too bright. If it ends more in the middle, then the
image is too dark.

Nevertheless there are always exception from the rule. A photo with a snow landscape will produce a similar histogram as
an overexposed photo, but the snow photo is fine while the overexposed photo needs to be fixed. On the other hand a
photo with a black sky and stars or the moon looks on the histogram as if it is underexposed, although that isn't the case.
So a good rule is to always investigate the image, too, and to not trust the histogram completely.

Small gaps tend do show up in the RGB Histogram more often than in other histogram types. They are only a sign that an
image was processed and are usually nothing to worry about.

Intensity, Luminosity and Lightness Histograms

The Intensity, Luminosity and Lightness histograms are very similar for many images. They often let you better judge the
brightness distribution in an image, but they are not suitable to judge blown highlights or cutoff shadows. If the image
contains more shadows, the hill is more on the left side. If it contains more highlights, the hill is located on the right side. If
it is well balanced, the hill or hills are usually in the middle of the histogram.

If there are two peaks, one on the outer left side in the shadows and one on the outer right side in the highlights, it means
that the photo was taken under extreme light conditions and contains too dark as well as too bright areas.

If there are peaks at both the outer left and right side, the image contrast is too extreme. In such a case you should
choose "Balance Midtones" from the Exposure Fix combo box or fine tune the image by using the Highlights and
Shadows sliders to compensate for it.

Red, Green, Blue, Cyan, Magenta and Yellow Histograms

These histograms can be used to recognize color casts or other color problems. For example if the Blue Histogram
contains a curve that is only located in the shadows, it means that there are as good as no light blue areas in the image.
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This can mean that the color blue was suppressed in the image and that the image has a yellow color cast.

Hue Histogram

The Hue histogram lets you see if some hues are missing. If some hues are dominant in the image, it can mean − but not
necessarily − that there is a color cast. A close−up photo for example is usually missing some hues even if it doesn't have
a color cast.

Saturation Histogram

The Saturation histograms lets you see if there is a problem with the saturation in the image. For example if there is
nothing in the left part, the image may be oversaturated or if there is nothing on the right side, the image is probably
undersaturated. However, images with a lot of white and dark areas may appear undesaturated according to the
histogram, but as pure white and black have no saturation, that may not be true.

Colors Histogram

The Colors histogram is similar to the RGB histogram, so it also lets you see if there are blown or cutoff areas.
Additionally it shows which hues are dominant in the shadows, midtones and highlights.

Black and White Histograms
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The left part of Black histogram and the right part of the White histograms are similar to the RGB histogram. Both
histograms should fill the whole value range from left to right for a good correction. The above Black histogram indicates
that the image is too "black" and too much "white" at the right end of the histogram is missing. The above White histogram
also has a larger gap at right end, which means that the white values aren't fully used.

If there is a large gap at the right or left end of the histogram, it means hat the contrast of the image is bad. Spikes at the
outer left or right indicate cut−off shadows and blown highlights.

Shadows and Highlights Histograms

The Shadows and Highlights histograms only take those image areas into account which are defined as shadows or
highlights by the mask controls in LightMachine. Changing the mask controls will also change the look of both histograms.
Both histograms are nice as a reference point when adjusting brightness and contrast in the shadows or highlights.

Styles

LightMachine lets you display the histograms in four different styles. "Filled" created the standard histogram type that is
known from many graphics applications. The "Gradient" option draws a color gradient from left to right. The colors of this
gradient are different from histogram to histogram. The "Line" option draws a line and leaves the area underneath empty.
"Dot" plots the histogram values as dots, which may make some histogram values less readable, but lets you easier
recognize a general trend.
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Info Tab

The Info tab shows information that is not essential but which may be helpful in certain circumstances.

Show Blown Highlights

If the Show Blown Highlights option is checked, highlight areas that were cutoff by LightMachine will be displayed as a line
pattern in the image. Additionally activating this check box shows a percent value in the check box label which indicated
the percentage of blown highlights. This feature doesn't show blown highlights that were already present in the image
before you executed LightMachine.

Color Box

When moving the mouse over the preview the color under the cursor is displayed in the color box of the Info tab sheet.
Additionally the color is shown as RGB and HSL values. The x and y values represent the image coordinates.
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Prefs Tab

The Prefs tab contains some options for defining the behavior of LightMachine.

On Start Up

The default On Start Up control is "Previous Settings". This option will load the settings last used to correct an image with
LightMachine. The "Default Settings" option will set all controls back to default values, which deactivates the automatic
contrast and exposure correction. "Original Image" will start LightMachine with no correction applied to the image.The
"Logged Settings" option will automatically open the settings that were applied the last time to the same image. It only
works if you previously had the Log Settings check box activated and if you are using Photoshop or Paint Shop Pro (see
below for more information).

On Reset

The behavior of the Reset button can be defined by the On Reset combo box. If it is set to "Default Settings" and click the
Reset button, it will deactivate most controls.

If On Reset is set to "Original Image" all corrections will be deactivated and the uncorrected image will be displayed in the
preview. If "Previous Settings" is activated on the Prefs tab, clicking Reset will load the settings that were used for
correcting the previous image. If you select "Own Defaults", you will be prompted to select an existing preset file. So, if
you want the Reset button to revert all controls back to your preferred settings, you must first save these settings to a
preset file. See below for more information on saving a preset file.

If you press the Reset button after setting On Reset to "Logged Settings", LightMachine will look in the logfiles subfolder
inside the LightMachine folder to see if a preset with the name of the current image has been saved there. This preset
may have been automatically saved by LightMachine, because the Log settings check box was activated and you already
applied a correction to this image (or an image with the same file name). If LightMachine can find a preset file, it will
immediately open it. If LightMachine doesn't find one, nothing will happen.

Language

The Language combo box lets you switch to another language. As a result all controls and messages in Lightmachine will
instantly appear translated to the selected language.

Instant Sliders

If the Instant Sliders check box is activated, the preview is updated while you drag a slider. Please notice that the Undo /
Redo feature won't work anymore if you have this check box activated. Instant Slider may also work too slow on
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computers with an older processor. You can also get the same effect if you hold down the Shift key while draggng a sldier.

Instant Preview

If the Instant Preview check box is activated, you can drag a spot light interactively over the preview in the Virtual Studio
modes. That makes it easier to place a spot light, because you see its effect while you are dragging it. This feature may
work too slow on computers with an older processor. In such a case it is more convenient to deactivate this check box.

Multi−CPU Off (x CPUs) (Windows Only)

If you encounter any problems, you can deactivate the support for multiple processors and hyperthreading processors
with this check box. The multiprocessor feature currently only extends to mask creation and the local contrast effect.The
number in brackets displays how many processors were detected by B/W Styler. For example, for a hyperthreading or
dualcore processor you will see "2 CPUs" displayed. If you only have a non−hyperthreading, singlecore processor, this
check box will be disabled by default.

Histo Zoom

Activating the Histo Zoom check box in the Prefs tab cuts off peaks for some images when displaying a histogram in the
Histo tab sheet. This avoids a flat histogram display where only a few high spikes are visible. That's also how Photoshop
displays histograms. This options is activated by default.

Log Settings

With the Log Settings check box activated LightMachine automatically saves preset files in the logfiles sub folder of the
LightMachine folder when you press the OK button to apply a correction to an image. In Photoshop and Paint Shop Pro
the presets are named with the file name of the image. In other applications a random number is used, because these
applications don't supply the file name of the image to plugins like LightMachine. If you apply LightMachine a second time
to the same image and have Log Settings activated, the previous preset file will be overwritten.

At least with Photoshop and Paint Shop Pro this feature allows you to easily find the settings that you applied to certain
images by looking into the logfiles sub folder. For other applications you can only look at the file date and guess which
preset files was used for which image.

In connection with the Logged Settings option of the On Start Up combo box (see above), you can use the Log Settings
check box to automatically make LightMachine start up with the settings that were applied the last time to the same
image. So if you need to correct the same image again, you will automatically be presented with the same settings that
you used the last time.

In case you don't want to start up LightMachine with the logged settings or forgot to activate that option, you can also
open the logged settings by right clicking on the Reset button and choosing "Logged Settings" from the context menu.
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Cloak Mode

In Cloak Mode LightMachine doesn't display its dialog and immediately starts rendering a predefined setting to the image.
Cloak mode is useful if you want to quickly apply the same settings to a series of photos.

Activating Cloak Mode

To activate Cloak Mode please hold down the CTRL key when you click on the Cancel button. The information box
pictured above will appear. After pressing YES, the current settings will be saved and LightMachine will be exited without
rendering any effects to the image.

When you run LightMachine again by choosing it from the Filter menu of your image application, the dialog of
LightMachine won't show up and the previous settings will be rendered immediately to the image. So if you have the On
Start Up combo box on the Prefs tab sheet set to "Default Settings", that is ignored in Cloak Mode and the previous
settings are applied. However, if you have On Start Up set to "Logged Settings", LightMachine will search for
automatically logged settings for each image and apply them if they are available.

If you want to apply LightMachine to a series of photos needing the same basic corrections using Cloak Mode, you can
test LightMachine on one or more of them and adjust the settings to match all or most of the photos.

Leaving Cloak Mode

After you have processed your series of photos in Cloak Mode you can uncloak LightMachine again. To do that, hold
down the Shift key when selecting LightMachine from the filter menu in your image application. This will display the
LightMachine dialog again and exit Cloak Mode.

Alternatively you can also delete the file Cloak.ini in the LightMachine folder. But this is just an emergency strategy.

Batch Processing using Cloak Mode in Photoshop

Photoshop offers a Batch feature on its File > Automate menu. This feature lets you batch process a series of images with
the help of a Photoshop Action. So if you want to batch process images in Photoshop you only need to record an action
that contains LightMachine.

LightMachine Manual 39



To record an action with LightMachine do the following:

1. Open an image in Photoshop.

2. Switch to the Actions palette at the right and create a new action by using the New Action button or the pop−up palette
menu.

3. Choose LightMachine from the Filter menu and press OK. You don't need to adjust any setting or enter Cloak mode
yet.

4. Press the Stop button on the Action palette. Now you have your LightMachine action that you can use with File >
Automate > Batch.

To batch process a series of images with LightMachine please do the following:

1. Open one of the images from the image series.
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2. Run LightMachine and adjust its settings.

3. Enter Cloak Mode by holding the CTRL key and clicking on the Cancel button.

4. Select File > Automate > Batch.

5. In the Batch dialog make sure that your LightMachine action is selected.

6. Set the other batch options and click on OK to run it.

If you want to batch process another series of images with other LightMachine settings, please uncloak LightMachine as
mentioned above, adjust the settings and return to Cloak Mode again. You don't need to create another action for that
purpose as you would need to do for other plugins.

If you want to apply individual LightMachine settings to each image during batch processing, run the action without
activating Cloak mode. In this case the LightMachine dialog will pop up for adjusting the settings for each image. To apply
them just click on OK.

Batch Processing in Cloak Mode in Paint Shop Pro 8 and higher

Paint Shop Pro 8 (and higher) offers a Process feature on the File >Batch menu for batch processing a series of images
with the help of a PSP script. Recording such a script is quite easy.

To record a PSP script with LightMachine, please do the following:

1. Open an image in PSP.

2. Select File > Script > Start Recording.

3. Choose LightMachine from the Filter menu and press OK. You don't need to adjust any setting or enter Cloak mode
yet.

4. Select File > Script > Stop Recording and save the script. Now you have a LightMachine action that you can use with
File > Batch > Process.
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To batch process a series of images with LightMachine please do the following:

1. Open one of the images from the image series.

2. Run LightMachine and adjust its settings.

3. Enter Cloak Mode by holding the CTRL key and clicking on the Cancel button.

4. Select File > Batch > Process.

5. In the Batch Process dialog choose your LightMachine script with the Browse button from the Script frame.

6. Set the other batch options and click on the Start button to run it.

If you want to batch process another series of images with other LightMachine settings, please uncloak LightMachine as
mentioned above, adjust the settings and return to Cloak Mode again. You don't need to create another script for that
purpose as you would need to do for other plugins. If you want to apply individual LightMachine settings to each image
during batch processing, don't activate Cloak mode and run the script nevertheless. Then for each image the
LightMachine dialog will pop up for adjusting the settings. To apply them just click on OK.

Batch Processing using Cloak Mode in other image editors

There are some other applications that support batch processing with the help of plugins. For example, Equilibrium
DeBabilizer supports it and some other applications like Plugin Commander Pro may support it in future. Basically batch
processing in other applications works the same as in Photoshop. You have to activate Cloak Mode in LightMachine and
select the LightMachine plugin for batch processing in the batch feature of these applications.
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Brightness / Contrast

The controls on the first tab sheet at the top can be used to correct the whole image in the Brightness/Contrast modes,
adjust the shadows in the Shadows/Highlights modes, brighten or darken all spot lights in the Virtual Studio modes and
modify certain color areas in the Color modes. The controls on the third tab sheet are identical and let you adjust the
highlights or background areas.

Brightness

The Brightness slider doesn't work like the brightness or gamma sliders that are known from many graphics applications.
It doesn't cut off shadows or highlights and also doesn't change the contrast. Its algorithm was specially developed for
adjusting photos.

Its unit is EV (exposure values) and goes from −5.0 EV to +5.0 EV. Only very dark areas need an adjustment of +4.0 EV
or higher. Images with average shadows only need adjustments of +1 or +2 EV. Above +4.5 EV, most images starts to
lose too much contrast, so it is recommended not to use the highest value of +5.0 EV very often.

Contrast

The Contrast slider is much more sophisticated than any contrast features that are included with graphics applications.
Values below zero can make some details more visible, but can create a more grayish look. Values above zero increase
contrast and give the image more punch, but may make some shadow details less visible. Sometimes you have to reduce
the contrast to match the look of a brightened area with its surroundings.

Amplify

The Amplify slider is meant to be used in addition to the Brightness and Contrast sliders. It offers further precision for
brightness and contrast adjustments for difficult images. It performs a white point adjustment for positive values and a
black point adjustment for negative values. Please use with care, because it can easily blow highlights or suppress
shadows.

Local Contrast

If you drastically increase the brightness, an image can easily lose local contrast. That means the edges in the image get
brighter, too, and are less distinguishable from the plain surface areas. To compensate for that effect you can use the
Local Contrast slider. Try smaller values at first, because too high values may darken, desaturate or blow the highlights in
the image too much. The additional Radius slider controls the pixel size of the local contrast effect. A higher value affects
a larger image area. Using a Local Contrast adjustment can easily double the render time.

Local Contrast enhancement is basically sharpening with a high radius. Sharpening is usually applied with a low radius of
0.1 to max. 4.0 pixel whereas a radius of 8 to more than 1000 pixel is used for a local contrast adjustment. A local contrast
adjustment increases the contrast in an image whereas sharpening makes image edges more recognizable. Local
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contrast enhancement and sharpening can be used in combination and don't exclude each other. However, I would only
use a Local Contrast adjustment if all other contrast adjustments fail like it is the case for extremely brightened up image
areas.

LightMachine Manual 44



Color

The controls on the second tab sheet at the top can be used to color correct the shadows in the Shadows/Highlights
modes, colorize all spot lights in the Virtual Studio modes and modify the color of certain color areas in the Color modes.
The controls on the fourth tab sheet are identical and let you adjust the color of the highlights or background areas.

The A and C buttons

The C button at the top left corner of the Color tab sheets appears in the Colors and Colors Pro mode whereas an A
button can be found in the same place in all other modes. The C button lets you pick a color from the preview. After
clicking the A button, please click on a color in the preview that you want to select. After that, the Method combo box as
well as the Red, Green and Blue sliders will be automatically adjusted with the selected color.

The A button works similar to the C button, but produces a different result. It lets you color correct the shadows, highlight,
spot or background areas semi−automatically. After clicking the A button, please click an image area in the preview that
you want to turn to white or gray. After that, the Method combo box as well as the Red, Green and Blue sliders will be
automatically adjusted with the opposite color of the color that you selected.

Method

The Method combo box offers four methods that determine how the shadows or highlights will be color corrected with the
values from the Red, Green and Blue sliders.

Adjust

The Adjust slider lets you weaken or strengthen the effect of the Red, Green and Blue sliders. Values below zero produce
a weaker color correction and values above zero increase the color correction intensity. A value of −100 neutralizes the
Red, Green and Blue values, so that no color correction is applied.

Red, Green and Blue

You can use these sliders to set the color with which the shadows or highlights are corrected. Negative values select the
antagonistic color, which is Cyan for Red, Magenta for Green and Yellow for Blue.

The selected color is displayed in the box at the left of the three sliders. You can also double click this color box to choose
a color from a color dialog. The Red, Green and Blue sliders will than be adjusted accordingly.
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Saturation

The combo box at the left of the Saturation slider lets you choose the saturation method. "Saturation" is the standard way
of adjusting saturation, but it may add artifacts at higher Saturation slider values. "Median Sat.", "Lumi Sat." and "Average
Sat." usually doesn't do that. The six last options represent color filters that suppress the saturation of the color they are
named after. For example, the "Protect Yellow" option keeps yellow objects from being saturated too much. It also
prevents too much color noise appearing in those yellow objects.

Positive values of the Saturation slider increase saturation in the shadows or highlights whereas negative values reduce
saturation. For normal correction saturation increases or decreases between −20 and 20 are sufficient. Some shadow
correction may create a serious saturation or B/W increase. If you are not able to compensate for that effect with other
sliders, you should consider using higher values for the Saturation slider.

Dragging the Saturation slider to the outer left position turns the image to B/W. Together with the Sat. Method combo box
this is another way to create B/W variations of your image.
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Auto Mask

The Auto Mask tab sheet is a good starting place when adjusting the shadow/highlight mask. It basically does the same
job as the Light Mask method of the Fine−Tune tab, but offers a more structured approach. This makes it easier to use for
beginners, but it also allow a quick correction for pros.

N, P, S, H

If one of these four buttons is activated you will see the mask that is used for the correction in the preview. The N button
shows a negative view of the mask, the P buttons shows the positive version of the mask. The S buttons shows only the
shadow areas, spot areas or selected color areas depending on which mode you are currently using. The H button shows
the highlight or background areas.

If you have Split View and the Multiple check box active, you can use these four buttons to display the processed image
side by side with the mask.

Shadow Depth

Lets you define how deep or flat the shadows are in the image. If you only want to have the really black shadows lifted,
you should select "Very Deep" or "Deep". For many cases a "Normal" setting will do. If you want the lower midtones
brightened up, too, you can select "Flat". Including the whole midtones is seldom necessary, but you can do that by
selecting "Very Flat".

If some shadow areas still look too dark, or if a strange border appears in the image you should select a stronger option. If
some areas are brightened up too much, try a lower setting. The Shadow Depth feature adjusts the Threshold slider on
the Fine−tune tab sheet.

Image Type

Image Type only offers two choices: "Low Contrast" for images that have a soft brightness graduation and no hard edges
where very bright areas meet very dark areas. "High Contrast" images on the other hand have one or more regions where
bright areas meet dark areas without a smooth transition. The Image Type feature sets the Range slider of the Fine−tune
tab to zero for high contrast images and to 100 for low contrast images.

Anti−Halo

If you chose "High Contrast" in the Image Type combo box the Anti−Halo feature will appear, otherwise the Shadow Shift
combo box will replace it. The Anti−Halo combo box offers three methods for halo removal at various strengths. There are
basically only two methods plus both combined.
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Halos are the bright glows that may appear where a bright image area meets a dark one. Method 1 tries to remove halos
by shifting the shadow/highlight border. It adjusts the Shift slider on the Fine−tune tab sheet. Method 2 tries to remove
halos by blending them away. That can be quite effective in some cases, but may decrease the effectivity of the shadow
removal or highlight suppression. It adjusts the Anti−Halo slider on the Fine−tune tab sheet. The Combined options
applies both methods for the really tough cases.

Shadow Shift

If you choose "Low Contrast" in the Image Type combo box the Shadow Shift feature will be displayed, otherwise the
Anti−Halo combo box will appear. The Shadow Shift feature decreases the size of the shadow areas in the shadow mask
thus keeping some shadows areas from being brightened. Shadow Shift adjusts the Shift slider on the Fine−tune tab
sheet.

Details

The Details combo box smoothes the shadow/highlight border and also produces a light diffusion effect at higher settings.
Although it avoids hard edges in the image, it can also create halos at high contrast borders in the image. Using a lower
Details setting isn't usually the best solution, so you should set Image Type to "High Contrast" and use the Anti−Halo
feature.

If you have a very thin border between dark and bright areas in the image, it is better to use a "Very Fine" or "Fine"
setting. If the brightness gradiations in the image are larger and softer, you can also use a "Large" or "Very Large" setting.
The Details feature adjusts the Radius slider on the Fine−tune tab sheet.

Color Filter

The Color Filter feature lets you exclude image objects with certain colors from the shadows and add them to the
highlights. If you want to add certain colored image areas to the shadows, you have to select the antagonistic color from
the Color Filter combo box. For Red that would be Cyan, for Green it would be Magenta, for Blue it would be Yellow and
vice versa.

The Color Filter feature adjusts the Color Filter slider on the Fine−tune tab sheet.
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Spot Mask

N, P, S, H

If one of these four buttons is activated you will see the mask that is used for the correction in the preview. The N button
shows a negative view of the mask, the P buttons shows the positive version of the mask. The S buttons shows only the
shadow areas, spot areas or selected color areas depending on which mode you are currently using. The H button shows
the highlight or background areas.

If you have Split View and the Multiple check box active, you can use these four buttons to display the processed image
side by side with the mask.

Managing Spots

LightMachine lets you create an unlimited number of spots. There is already one spot, which can't be deleted, available
from the start.

To create a new spot simply click somewhere on the preview where you want to have it placed. The new spot will have
the properties of the spot that was selected before the new spot was created. So if you want a new spot to have the
properties of a existing spot, please select that spot first. To delete a spot simply click the Del or Backspace key.

The currently selected spot is always surrounded by a marquee and has a broken−up rectangle around its center cross.
To select another spot simply click on its cross. Alternatively you can also use the numeric key to select one of the first 10
spots or use the Spot button menu (see below).

To drag a spot click on its cross and drag it by moving the mouse while keeping the left mouse buttons pressed. You can
also move the currently selected spot by 10 pixel with the cursor keys. If you additionally hold down the CTRL key, the
spot will be moved by 100 pixel.

The spot that is selected can be adjusted with the controls from the Spot Mask tab sheet. If you want to adjust the
properties of another spot, please select that spot.
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The Spot Button Menu

Clicking the small icon left of the Intensity slider displays the spot button menu. This menu contains commands for hiding
and showing spots, pasting spot properties to other spots and selecting spots.

The Hide Spots command hides the cross of each spot light and the surrounding circle of the currently selected spot light.
If you use too many spot light, these marks can obscure the image. So deactivating this button lets you see the image
more clearly. If you want to makes them visible again, the button menu will offer the Show Spots command.

The Paste to all Spots sub menu lets you transfer certain or all properties of the currently selected spot to all available
spots. This way you don't need to select each spot and adjust it individually if you want them to have the same properties.
The Paste All Properties To sub menu lets you transfer all properties of the currently selected spot to one of the other
spots.

Please remember that you only need to use these commands if all your spots are already created. Otherwise if you create
a new spot it will automatically get the properties of the selected spot.

Finally, the Spot 1 to Spot n commands at the bottom of the menu let you switch between the available spots. Clicking
one one of the menu items will select that spot. The spots are numbered according to their creation time. The first spot
that was created is Spot 1, the second is Spot 2 and so on. Alternatively you can also select a spot with the numeric keys,
which is faster.

Intensity

The Intensity slider defines the intensity of the currently selected spot light. At a value of 255 the effects from the Spots
and S−Color tab sheets (e.g. brightness, contrast or color) are applied at full intensity to image areas that are covered by
the spot light. A value of zero deactivates the spot light. Values below zero turn the light spot into a shadow spot. At −255
the shadow spot has its highest intensity.

The effect of sliders on the Spots tab sheet (e.g. brightness and contrast) are uniformly applied to all spots. So the sliders
on the Spots tab sheet should be set according to the brightest spot. The other spots can be made darker by selecting
each one and decreasing the Intensity slider on the Spot Mask tab sheet.

Size

With the Size slider you can increase the size of the spot light in percent. The value refers to the width or height of the
image (whichever is smaller). That means can be maximally as large as the image itself. The relative value of this slider
means that you can use the same spots without any modifications with upsized or downsized versions of the same image.

Ovality and Angle

The Ovality slider lets you turn the circular spot light into an oval one. The higher the Ovality slider the thinner is the
spotlight. The Angle slider only works if the Ovality slider is higher than zero. If the spot light is still totally circular, you can
see any rotation because of the symmetry of a circle.

At a Angle value of zero an oval spotlight is orientated vertically. To get a horizontal spotlight, you need to set Angle to a
value of 90.

Hardness

The Hardness slider makes the light of the spot harder, which means that the light is more concentrated on an area and
less diffused. At a value of zero the spot light has is brighter in the middle than at the border areas. Increasing the
Hardness of a spot light will make the middle areas brighter. The spot light appears bigger then, although it wasn't
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enlarged. A higher Hardness value will also make the transition area between the spot light and the outer areas smaller
and less smooth. So a larger spot light is often a better alternative.

Reflection

The Reflection slider defines how much light is "reflected" from the image area that is covered by the currently selected
spot light. A value of 100 will "reflect" all light, which means that the image area will be brightened at full intensity. That
can easily produce blown highlight. The default value of zero often produces more natural results. Decreasing the
Reflection value up to −100 will decrease the reflection even more and keep already bright areas from being brightened.

You can adjust the reflection properties of the whole image by adjusting the controls from the Reflection tab sheet. The
settings of the controls on that tab sheet are applied to all spots and can't be set separately for each spot. These controls
are identical to those of the Fine−Tune tabs sheet of the Shadows/Highlights modes. It may be a good ideas to adjust
them in the Shadows/Highlights (Pro) mode and afterwards return back to the Virtual Studio (Pro) mode.With these
controls you can precisely reduce the reflection of highlight areas, reduce halos that are produced by spot lights and much
more.
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Fine−Tune / Reflection

The Fine−tune tab sheet from the Shadows/Highlights modes and the Reflection tab sheets from the Virtual Studio modes
are identical. The only difference is that the mask that is adjusted with the Fine−tune tab sheet separate the shadows and
highlights whereas the Reflection tab sheet controls the shape the spot lights. The adjustments of the Fine−tune tab sheet
in Shadows/Highlights (Pro) mode can be useful in Virtual Studio (Pro) mode and vice versa. LightMachine automatically
carries them over when switching modes.

N, P, S, H

If one of these four buttons is activated you will see the mask that is used for the correction in the preview. The N button
shows a negative view of the mask, the P buttons shows the positive version of the mask. The S buttons shows only the
shadow areas, spot areas or selected color areas depending on which mode you are currently using. The H button shows
the highlight or background areas.

If you have Split View and the Multiple check box active, you can use these four buttons to display the processed image
side by side with the mask.

Method

The Method combo box offers four choices for creating a shadows/highlight mask or reflection mask. The first three
options are simpler methods whereas the fourth "Light Mask" method is a combination of the previous three methods.
When using the Auto Mask tab sheet the Method feature is automatically switched to"Light Mask".

The Contrast Mask method was already used in the pre−digital days in photo labs. There are some Photoshop tutorials on
the web about it, but LightMachine uses a different and more effective technique that is closer related to the non−digital
method. An advantages of Contrast Mask is the good shadow recovery, but it tends to produce halo effects and also
brighten highlights. The Brightness Mask method works similar to the Shadow/Highlight tool from Photoshop. It's biggest
advantage is that no halos are produced at all. On the other hand it offers a less effective shadow recovery and brightens
highlights, too. The B/W Mask method, which is also used by some other plugins, offers the best shadow recovery and
doesn't brighten highlights, but like Contrast Mask it also tends to produce halo effects.

The Light Mask combines the advantages of the above mentioned methods. It features a very good shadow recovery,
doesn't brighten highlights and allows you to suppress halos. It also offers more features for flexibly adjusting the mask to
the image.

Stretch

The Stretch check box is activated by default, because it usually creates a stronger brightness correction by increasing
the contrast of the mask. Deactivating the Stretch check box can sometimes help when you use very high Radius sliders.
However, readjusting the Radius slider is sometimes the better alternative.
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Threshold

The Threshold slider lets you define the border between shadows and highlights in terms of brightness values from 0 to
255. If you split the brightness range into shadows, midtones and highlights, the shadows would run from 0 to 85 (255 / 3
= 85). So the Threshold value would have to be set to 85. This value works very nicely for many images. However, if an
image has deeper shadows, a value of 43 (which is approx. half of 85) may produce better results. If an image has
weaker shadows, a value of 128 may work even better. Only in few cases a value of 21 or 170 will work best.

Please remember, if you use a Threshold value of 85, the highlights will run from 86 to 255. If you only want lift the
shadows that value will be fine. If you want to adjust the shadows and highlights, a value of 128 may work better. If you
only want to target the highlights and leave the shadows untouched, you can also use a value of 170 or higher.

Range

If the Light Mask method is used, setting the Range slider to zero will keep the shadows and highlight areas separate from
each other. Higher values gradually blend the shadow and highlight areas together. With a value of 100 the shadows and
highlights will both be affected by the controls from the Shadows and Highlight (or Selected and Back) tab sheets.
Non−zero values are only recommended for images that have soft brightness graduations. This type of image looks better
if shadows and highlights aren't corrected separately.

For the Contrast Mask and Brightness Mask methods you should try keep the Range slider in the middle of the value
range, e.g. at 50. Higher or lower values usually have an adverse effect on the correction.

Shift

The Shift slider lets you shrink the shadow areas and enlarge the highlight area in the mask. It can be used to reduce
halos or to adjust the size of the shadows and highlight areas. A value of 100 will remove the shadows areas from the
mask.

Anti−Halo

As the name says the Anti−Halo slider is mainly intended for removing halos. A value of 1 already has quite some effect.
Values above 50 aren't really recommended, as they can weaken the correction.

Radius

The Radius slider smoothens the transition between shadow and highlight areas. Its maximum value changes from image
to image, because it is set according to the size of the image. Too high values will blend the shadow and highlight areas
too much. Too low values can produce hard edges. The Radius slider also determines the size of halos along high
contrast borders in the image. Nevertheless, it is recommended to lower its values. It is usually better to use the Shift or
Anti−Halo sliders. Using a very high radius value may also make halos less visible.

Lower Radius values are recommended for images with small and contrasty details. However, too high Radius values can
sometimes make a correction look unnatural. So you often have to choose the best compromise when setting the Radius
value.

Color Filter

The Color Filter slider lets you choose the color which shall be excluded from the shadows and added to the highlights. If
you want to add image areas with a certain color to the shadows, you have to select the antagonistic color with the Color
Filter slider. For Red that would be Cyan, for Green it would be Magenta, for Blue it would be Yellow and vice versa.
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Color Mask

N, P, S, H

If one of these four buttons is activated you will see the mask that is used for the correction in the preview. The N button
shows a negative view of the mask, the P buttons shows the positive version of the mask. The S buttons shows only the
shadow areas, spot areas or selected color areas depending on which mode you are currently using. The H button shows
the highlight or background areas.

If you have Split View and the Multiple check box active, you can use these four buttons to display the processed image
side by side with the mask.

Adding Colors to the Mask

The easiest way to add a color to the color mask is by clicking on that color on the preview. When you do that, the Color
combo box automatically switches to the color and sets the Intensity slider to a value of 255. To remove a color from the
color mask again shift click on that color in the preview.

It works best if you select a color that is limited to a certain image area. Colors that are distributed over various image
objects and areas and without strict color borders are less suitable. Also, if an image has a color cast that spreads all over
the image can decrease the effectively of the Colors modes. In such a case it is best to correct the color cast at first.
However, if you only want to adjust the brightness and contrast of a color area, it don't matter much that much and even
overlapping color areas work fine. Using the Smoothness slider can help, too.

Color

The Color combo box lets you select the six main colors Red, Green, Blue, Cyan, Magenta and Yellow. The four sliders
beneath can have different values for each of the six color options. The slider values of each color option are used to
create a color mask.

Invert

The Invert check box lets you invert the color mask.

Intensity

Defines how much the color that is selected in the Color combo box contributes to the color mask. If it is set to zero, the
image areas with that color are ignored. If it is set to 255, image areas with that color are added to the mask.
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Impact

The Impact slider lets you intensify the selected color. It increases the contrast of that color in the color mask and
increases the intensity of the applied effect. Values up to 50 are recommended, but higher values may produce hard
edges in the image.

Radius

The Radius slider lets you smooth the individual mask of the currently selected color. This can be helpful to create a
smooth transition and avoid hard edges, but a too high value may also produce unwanted glow effects, so−called halos.

Range

The Range slider lets you shrink or expand the range of the currently selected color and exclude currently selected areas
or include other areas, too.
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